Bug 1568804 - [RFE] Use ActiveMQ Artemis for Providers
Summary: [RFE] Use ActiveMQ Artemis for Providers
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Performance
Version: 5.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: GA
: cfme-future
Assignee: Jason Frey
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks: 1591597
TreeView+ depends on / blocked
 
Reported: 2018-04-18 09:16 UTC by Oleg Barenboim
Modified: 2019-12-17 16:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-17 16:57:41 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Oleg Barenboim 2018-04-18 09:16:28 UTC
Description of problem:

Use ActiveMQ Artemis for Provider Integrations.

1. In order to do that, we need to add Artemis into the Appliance and be able to enable it via configuration.
2. Leverage for Provider Events.
3. Leverage for Provider Metrics.
4. Leverage for Provider Inventory.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Dave Johnson 2018-04-18 09:44:56 UTC
Please assess the impact of this issue and update the severity accordingly.  Please refer to https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity for a reminder on each severity's definition.

If it's something like a tracker bug where it doesn't matter, please set the severity to Low.

Comment 3 Adam Grare 2018-05-14 19:12:38 UTC
Assigning top-level tracking BZ to Jason

Comment 4 Oleg Barenboim 2019-12-17 16:56:30 UTC
We have decided to use Kafka, and this BZ is tracked upstream in the following:

https://github.com/ManageIQ/manageiq/issues/19583
https://github.com/ManageIQ/manageiq/issues/19584
https://github.com/ManageIQ/manageiq-appliance-build/issues/374

Because it is tracked in the upstream, I will close this BZ.


Note You need to log in before you can comment on or make changes to this bug.