Bug 1568885 - uncomplete devel package
Summary: uncomplete devel package
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: krdc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-18 11:26 UTC by Fl@sh
Modified: 2018-04-21 12:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-21 12:48:51 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
KDE Software Compilation 393365 0 None None None 2018-04-21 12:48:51 UTC

Description Fl@sh 2018-04-18 11:26:16 UTC
Description of problem:
krdc-devel not contains

vnc/vncview.h
vnc/vncclientthread.h

and related headers for unbandled build viewers with VNC.

Version-Release number of selected component (if applicable):
krdc-17.12.3-1.fc29.rpm

How reproducible:
rpm -q --filesbypkg krdc-devel


Actual results:
krdc-devel                /usr/include/krdc
krdc-devel                /usr/include/krdc/hostpreferences.h
krdc-devel                /usr/include/krdc/remoteview.h
krdc-devel                /usr/include/krdc/remoteviewfactory.h
krdc-devel                /usr/include/krdccore_export.h
krdc-devel                /usr/lib64/libkrdccore.so

Expected results:
krdc-devel                /usr/include/krdc
krdc-devel                /usr/include/krdc/hostpreferences.h
krdc-devel                /usr/include/krdc/remoteview.h
krdc-devel                /usr/include/krdc/remoteviewfactory.h
krdc-devel                /usr/include/krdc/vnc/vncview.h
krdc-devel                /usr/include/krdc/vnc/vncclientthread.h
krdc-devel                /usr/include/krdccore_export.h
krdc-devel                /usr/lib64/libkrdccore.so

Additional info:
https://cgit.kde.org/krdc.git/tree/vnc

Comment 1 Rex Dieter 2018-04-18 12:06:22 UTC
I'd recommend you reach out to upstream why these are not included... perhaps they are not intended to be part of the public api (just a guess for one possible reason).

Comment 2 Fl@sh 2018-04-21 07:52:57 UTC
Created the bug in upstream: https://bugs.kde.org/show_bug.cgi?id=393365

Comment 3 Rex Dieter 2018-04-21 12:48:51 UTC
Thanks, will continue tracking there


Note You need to log in before you can comment on or make changes to this bug.