Bug 1568893 - Alert when guaranteed capacity reaches a threshold value
Summary: Alert when guaranteed capacity reaches a threshold value
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Gluster
Version: 4.2.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.2.5
: ---
Assignee: Denis Chaplygin
QA Contact: bipin
URL:
Whiteboard:
Depends On:
Blocks: 1518541 1520833
TreeView+ depends on / blocked
 
Reported: 2018-04-18 11:47 UTC by Sahina Bose
Modified: 2018-07-31 15:29 UTC (History)
6 users (show)

Fixed In Version: ovirt-engine-4.2.5.2
Doc Type: Enhancement
Doc Text:
Feature: Notification on running our of physical space. Reason: With VDO and Thin pool support, users may see more space, that it is available physically. This is totally fine and with VDO it is an expected behavior. At the same time, we can't predict, how much data user will be able to actually write. Because of that, to keep user informed, we would like to notify him, when he is running out of physical space and, at the same time, show him how much confirmed space he have. Result: When actually used space of the thin device goes above configured threshold, event will be issued.
Clone Of:
Environment:
Last Closed: 2018-07-31 15:29:06 UTC
oVirt Team: Gluster
dchaplyg: needinfo-
rule-engine: ovirt-4.2?
sasundar: blocker?
sasundar: planning_ack?
rule-engine: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)
Screenshot_Verified (73.35 KB, image/png)
2018-07-26 06:27 UTC, bipin
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90965 0 'None' MERGED storage: Added low confirmed space threshold column 2020-02-17 13:10:11 UTC
oVirt gerrit 90966 0 'None' MERGED gluster: Added calculation of the total size of the thin device. 2020-02-17 13:10:11 UTC
oVirt gerrit 90967 0 'None' MERGED gluster: Added storing total physical device size in BrickProperties 2020-02-17 13:10:11 UTC
oVirt gerrit 90968 0 'None' MERGED gluster: Added 'confirmed space low' event 2020-02-17 13:10:11 UTC
oVirt gerrit 91323 0 'None' MERGED storage: Added low confirmed space threshold column 2020-02-17 13:10:11 UTC
oVirt gerrit 91324 0 'None' MERGED gluster: Added calculation of the total size of the thin device. 2020-02-17 13:10:11 UTC
oVirt gerrit 91325 0 'None' MERGED gluster: Added storing total physical device size in BrickProperties 2020-02-17 13:10:11 UTC
oVirt gerrit 91326 0 'None' MERGED gluster: Added 'confirmed space low' event 2020-02-17 13:10:12 UTC
oVirt gerrit 91327 0 'None' MERGED ui: Added 'low confirmed space threshold' setting 2020-02-17 13:10:12 UTC
oVirt gerrit 91761 0 'None' MERGED ui: Added 'low confirmed space threshold' setting 2020-02-17 13:10:12 UTC
oVirt gerrit 92247 0 'None' MERGED gluster: Inverted 'Low confirmed storage' event threshold 2020-02-17 13:10:12 UTC
oVirt gerrit 92279 0 'None' MERGED gluster: Inverted 'Low confirmed storage' event threshold 2020-02-17 13:10:12 UTC
oVirt gerrit 93042 0 'None' MERGED gluster:Inverted threshold comparition for thin device alerting. 2020-02-17 13:10:12 UTC
oVirt gerrit 93063 0 'None' MERGED gluster: Added unittest for capacity calculation 2020-02-17 13:10:12 UTC
oVirt gerrit 93064 0 'None' MERGED gluster:Inverted threshold comparition for thin device alerting. 2020-02-17 13:10:12 UTC

Description Sahina Bose 2018-04-18 11:47:19 UTC
Description of problem:

Monitoring of gluster bricks/volumes takes into consideration the thinpool and vdo devices that are configured for a brick directory and reports the guaranteed available space as seen by brick/volume

An alert should be raised when this guaranteed capacity drops below 80/90 % of total available space. The threshold at which alerted should be configurable.

Version-Release number of selected component (if applicable):


How reproducible:
NA

Steps to Reproduce:
NA



Additional info:

Comment 1 Sandro Bonazzola 2018-05-25 07:26:31 UTC
Moving back to post since referenced patch http://gerrit.ovirt.org/91327 is still open on master branch

Comment 5 Red Hat Bugzilla Rules Engine 2018-06-13 12:14:16 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 9 Sandro Bonazzola 2018-06-15 12:17:44 UTC
This bug is not marked as blocker and we entered blocker only phase for 4.2.4.
Please consider re-targeting to 4.2.5.

Comment 12 SATHEESARAN 2018-07-11 10:16:03 UTC
This bug is re-opened and was working with the previous build in RHV 4.2.4 ( current release ). Hence added 'Regression' keyword. Also this test cases it the release blocker for RHHI 2.0 as the VDO monitoring alert is the requirement for this release.

Comment 13 SATHEESARAN 2018-07-12 06:41:39 UTC
(In reply to SATHEESARAN from comment #12)
> This bug is re-opened and was working with the previous build in RHV 4.2.4 (
> current release ). Hence added 'Regression' keyword. Also this test cases it
> the release blocker for RHHI 2.0 as the VDO monitoring alert is the
> requirement for this release.

I wish to clarify my earlier comment - " was working with previous build". Here alerts were not working with previous builds too.

Comment 15 Sandro Bonazzola 2018-07-24 16:10:04 UTC
Should be included in ovirt-engine-4.2.5.2

Comment 16 bipin 2018-07-26 06:26:48 UTC
Verified the bug in ovirt-engine-4.2.5.2.

Steps:
=====
1.Create a vdo based storage domain
2.Create a volume of size 899GB
3.Set the "warning low space indicator" to 98 and "warning low confirmed space indicator" to 97
4.Saw the alerts which it reached that point


Attaching the screenshot

Logs from HE:
============
2018-07-26 11:11:30,848+05 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (EE-ManagedThreadFactory-engineScheduled-Thread-79) [] EVENT_ID: IRS_DISK_SPACE_LOW_ERROR(201), Critical, Low disk space. vdo_sdd domain has 879 GB of free space.

2018-07-26 11:11:10,692+05 WARN  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (EE-ManagedThreadFactory-engineScheduled-Thread-79) [] EVENT_ID: IRS_DISK_SPACE_LOW(26), Warning, Low disk space. vdo_sdd domain has 881 GB of free space.

Comment 17 bipin 2018-07-26 06:27:29 UTC
Created attachment 1470605 [details]
Screenshot_Verified

Comment 18 bipin 2018-07-26 10:28:36 UTC
Canceling the needinfo, since the bug is verified

Comment 19 Sandro Bonazzola 2018-07-31 15:29:06 UTC
This bugzilla is included in oVirt 4.2.5 release, published on July 30th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.5 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.