Bug 1568997 - Logical size of the devices should be 10 times of the physical size
Summary: Logical size of the devices should be 10 times of the physical size
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhhi
Version: rhhiv-1.5
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Sahina Bose
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On: 1569000
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-18 13:35 UTC by bipin
Modified: 2019-11-20 08:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1569000 (view as bug list)
Environment:
Last Closed: 2019-11-20 08:52:39 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description bipin 2018-04-18 13:35:12 UTC
Description of problem:
Currently the Logical size for VDO is 10 times the sum of all bricks created. But the logical size should always be 10 times of the physical size of device.
ie:
If the device /dev/sdb has a size of the of 20T. Then the logical size should be 200T. This should be irrespective of the brick size selected for each volume.

Also considering a scenario where, if the device size is 20 TB and a volume created out of it is 1T then the logical size will be 10T. Which is less than the physical size. (physical size 20TB > logical size 10 T). This is not recommended according to VDO. 
This also eliminates the work of adding the logical size every time we create a new volume.

NOTE: Also had previously confirmed the same with Dennis Keefe. Please find the comment below:

    2. vdoLogicalSize = 10 x ( Disk physical size )
    In actual, the cockpit implementation does 4 x size of physical disk.
    I read from the RHEL 7.5 storage admin guide, about the recommendation of 10:1


 The cockpit implementation will allow much large size, though you have to manually change the settings.
10x is typical for VMs.  I agree with this setting.


Version-Release number of selected component (if applicable):
cockpit-ovirt-dashboard-0.11.21-1.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Login to cockpit UI
2. Start gluster deployment 
3. Select the  enable compression and dedupe check

Actual results:


Expected results:


Additional info:

Comment 1 Sahina Bose 2019-10-11 10:37:27 UTC
Any plans to integrate with cockpit storage module to get this info?

Comment 2 Gobinda Das 2019-10-11 11:18:56 UTC
Cockpit storage module can fetch device info from localhost only, trying to find way how to get device info from other nodes as well. May be via ansible.


Note You need to log in before you can comment on or make changes to this bug.