Bug 1569018 - metrics from openshift 3.6 are not being collected properly by CloudForms 4.6.1
Summary: metrics from openshift 3.6 are not being collected properly by CloudForms 4.6.1
Keywords:
Status: CLOSED DUPLICATE of bug 1562090
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: All
OS: All
unspecified
high
Target Milestone: GA
: cfme-future
Assignee: Bronagh Sorota
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-18 13:58 UTC by Felix Dewaleyne
Modified: 2018-04-18 14:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-18 14:25:38 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Felix Dewaleyne 2018-04-18 13:58:02 UTC
Description of problem:
metrics from openshift 3.6 are not being collected properly by CloudForms 4.6.1 - the appliance thinks that there are no records while there definitely are and they are visible through hawkular 

Version-Release number of selected component (if applicable):
5.9.1 & ocp 3.6


How reproducible:
customer environment 

Steps to Reproduce:
1. connect ocp to 5.9.1 using the official guide [1]
2. enable metrics collection as documented and generate some load on ocp (only using hawkular, no prometeus in use)
3.

Actual results:]
[----] W, [2018-04-18T09:44:23.400910 #13357:d0910c]  WARN -- : MIQ(ManageIQ::Providers::Kubernetes::ContainerManager::MetricsCapture#perf_collect_metrics) Metrics missing: [ContainerGroup(20000000000098)] no gauge metrics found for [app-b-1-5nxbv]

Expected results:
metrics are collected for 3.6

Additional info:
[1] - https://access.redhat.com/documentation/en-us/red_hat_cloudforms/4.6/pdf/integration_with_openshift_container_platform/Red_Hat_CloudForms-4.6-Integration_with_OpenShift_Container_Platform-en-US.pdf

Comment 5 Felix Dewaleyne 2018-04-18 14:25:38 UTC

*** This bug has been marked as a duplicate of bug 1562090 ***


Note You need to log in before you can comment on or make changes to this bug.