Bug 1569083 - Wrong (generic Fedora) branding shown during install from Workstation live images
Summary: Wrong (generic Fedora) branding shown during install from Workstation live im...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 28
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F28FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2018-04-18 15:07 UTC by Adam Williamson
Modified: 2018-04-25 16:30 UTC (History)
14 users (show)

Fixed In Version: anaconda-28.22.9-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-24 11:25:06 UTC
Type: Bug


Attachments (Terms of Use)

Description Adam Williamson 2018-04-18 15:07:13 UTC
In current Fedora 28, during install from the Workstation live image, generic 'Fedora' branding is shown. The Workstation-specific branding is not.

Proposing as a Final blocker, clearly violates "For each Edition, the installer must be clearly identified as that Edition in all of that Edition's installable release-blocking images" - https://fedoraproject.org/wiki/Fedora_28_Final_Release_Criteria#Self-identification .

Note there is a fix for this already: https://github.com/rhinstaller/anaconda/pull/1441

Comment 1 Patrick Uiterwijk 2018-04-18 15:11:47 UTC
1 blocker

Comment 2 Mohan Boddu 2018-04-18 15:13:41 UTC
+1 Blocker

Comment 3 Kevin Fenzi 2018-04-18 15:14:48 UTC
+1 blocker

Comment 4 Adam Williamson 2018-04-18 15:20:03 UTC
That's +4, accepting.

Comment 5 Jared Smith 2018-04-18 15:40:20 UTC
+1 blocker.

Comment 6 Adam Williamson 2018-04-19 19:21:44 UTC
I thought the proposed fix for this looked wrong (looks like it will also apply to non-Workstation lives), and proposed an alternative:

https://github.com/rhinstaller/anaconda/pull/1448

Comment 7 Fedora Update System 2018-04-20 18:33:52 UTC
anaconda-28.22.9-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-006bec3ab8

Comment 8 Fedora Update System 2018-04-21 18:39:08 UTC
anaconda-28.22.9-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-006bec3ab8

Comment 9 Lukas Ruzicka 2018-04-23 13:00:03 UTC
The latest version of Anaconda 28.22.9-1 solves the problem described.

Comment 10 sumantro 2018-04-24 02:48:19 UTC
 The update works fine, Although I can reproduce the same in Fedora-28-20180423.n.0

Comment 11 Fedora Update System 2018-04-24 11:25:06 UTC
anaconda-28.22.9-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Adam Williamson 2018-04-25 16:30:38 UTC
For the record, openQA tests demonstrate the theming is properly in place in the RC1 compose, e.g. https://openqa.fedoraproject.org/tests/229697#step/_boot_to_anaconda/9 .


Note You need to log in before you can comment on or make changes to this bug.