Bug 1569116 - Hyperconverged wizard is not disabled when gdeploy is not present
Summary: Hyperconverged wizard is not disabled when gdeploy is not present
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Gdeploy
Version: 0.11.20
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.2.3
: ---
Assignee: Parth Dhanjal
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-18 15:51 UTC by Denis Chaplygin
Modified: 2018-05-10 06:28 UTC (History)
11 users (show)

Fixed In Version: cockpit-ovirt-0.11.23-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 06:28:40 UTC
oVirt Team: Gluster
sabose: ovirt-4.2?
sabose: blocker?
sabose: planning_ack?
sabose: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 90566 master MERGED RHHI Deployment Wizard to stop if Gdeploy not available 2018-04-24 17:53:32 UTC
oVirt gerrit 90609 ovirt-4.2 MERGED RHHI Deployment Wizard to stop if Gdeploy not available 2018-04-24 18:01:07 UTC

Description Denis Chaplygin 2018-04-18 15:51:07 UTC
Description of problem: When gdeploy is not present user still can run hyperconverged wizard and it will fail


Version-Release number of selected component (if applicable): master


How reproducible: always


Steps to Reproduce:
1. install cockpit and cockpit ovirt plugin
2. Make sure you don't have gdeploy installed on the same host
3. Start hyperconverged setup wizard. It will start successfully and silently fail at the end of the wizard

Actual results: Wizard start and silently fails when i tries to run gdeploy


Expected results: Wizard should not start and tell user, that gdeploy is not available

Comment 1 SATHEESARAN 2018-04-28 08:45:01 UTC
Tested with cockpit-ovirt-dashboard-0.11.23.el7rhgs.

Installation wizard throws warning, and doesn't allows to proceed with installation, when gdeploy is not available

Comment 2 Sandro Bonazzola 2018-05-10 06:28:40 UTC
This bugzilla is included in oVirt 4.2.3 release, published on May 4th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.