Bug 1569184 - [RFE] Puppet should be run automatically as part of OpenSCAP scan remote execution
Summary: [RFE] Puppet should be run automatically as part of OpenSCAP scan remote exec...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Remote Execution
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Peter Ondrejka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-18 18:14 UTC by lkerner
Modified: 2019-11-04 14:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-04 14:02:08 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description lkerner 2018-04-18 18:14:14 UTC
Description of problem:
Currently, after a change to a compliance policy(like adding a tailoring file), you have to manually run puppet on the client prior to running the OpenSCAP scan via remote execution in the Satellite GUI. Puppet should be run automatically as part of OpenSCAP scan remote execution. 

Version-Release number of selected component (if applicable): Satellite 6.3.0


How reproducible:
100% 

Steps to Reproduce:
1. Make a change to a compliance policy in the Satellite GUI(like adding a tailoring file)
2. Run OpenSCAP scan via remote execution 
3. Notice that the scan report is not updated with the changed compliance policy results since puppet agent -t wasn't run on the client manually.

Actual results:
Scan report is not updated with the changed compliance policy results.

Expected results:
Puppet should be run automatically as part of OpenSCAP scan remote execution and the scan report results should be updated with the changed compliance policy results.

Additional info:

Comment 1 Bryan Kearney 2019-11-04 14:02:08 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.