Bug 1569215 - php-fpm should provide php(httpd)
Summary: php-fpm should provide php(httpd)
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: php
Version: 7.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Remi Collet
QA Contact: RHEL Stacks Subsystem QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-18 19:50 UTC by Robert Scheck
Modified: 2021-01-14 09:27 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-06 15:42:01 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Robert Scheck 2018-04-18 19:50:21 UTC
Description of problem:
Given bug #1215429 was only solved half (package php provides php(httpd),
but package php-fpm doesn't provide it as well), this is the request to
have a common provide at both, php and php-fpm that could be used e.g. by
packages like phpMyAdmin which could work with mod_php or php-fpm.

Version-Release number of selected component (if applicable):
php-5.4.16-45.el7

How reproducible:
Always, see above.

Actual results:
Package php-fpm doesn't provide php(httpd).

Expected results:
Package php-fpm should provide php(httpd).

Additional info:
https://git.centos.org/commitdiff/rpms!php.git/4bf89e58d6d5bfd9999c38269ab4dd548af8f9a0

Comment 2 Robert Scheck 2018-04-18 19:55:08 UTC
Linked with ticket 01436505 at Red Hat customer portal.

Comment 6 Remi Collet 2018-12-10 09:28:22 UTC
> Package php-fpm should provide php(httpd).

only mod_php (php package) provides a working configuration.

php-fpm does NOT (this was explained in the original bug report)

Comment 8 Robert Scheck 2018-12-10 10:48:51 UTC
Right. And according to bug #1215429 comment #4, I would like to see the needed rest as well in RHEL 7. Given that php-fpm will be preferred in RHEL 8, it's IMHO even a good argument to introduce such a switch in RHEL 7.

Comment 9 Joe Orton 2019-06-06 15:42:01 UTC
As Remi explained in bug 1215429, Provides: php(httpd) is intended to indicate the package provides working PHP in the default configuration.

We do provide that in php-fpm in RHEL8 (which is supported).

We don't provide that via php-fpm in RHEL7, which is an unsupported package in the optional channel. https://access.redhat.com/solutions/62331

We don't have any plans to change this in RHEL7, sorry Robert.


Note You need to log in before you can comment on or make changes to this bug.