Bug 1569251 - Fedora 27 Cinnamon Spin does not upgrade to F28 - xed not in distupgrade repository
Summary: Fedora 27 Cinnamon Spin does not upgrade to F28 - xed not in distupgrade repo...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xed
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alternative GTK desktop environments
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-18 21:47 UTC by bernhard
Modified: 2018-04-19 07:24 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-19 07:24:40 UTC
Type: Bug


Attachments (Terms of Use)

Description bernhard 2018-04-18 21:47:17 UTC
Description of problem:

Upgrade of F27 Cinnamon spin not possible with 
dnf system-upgrade download --refresh --releasever=28


Version-Release number of selected component (if applicable):

F27 got "dnf upgrade" and reboot before


How reproducible: Reproduced on 2 virtual machines running F27


Steps to Reproduce:
1. see above command
2.
3.

Actual results:

problem with installed package xed-1.6.2-1.fc27.x86_64
- xed-1.6.2-1.fc27.x86_64 does not belong to a distupgrade repository
- nothing provides libgspell-1.so.1()(64 bit) needed by xed-1.6.4-0-1.20180309git3733860.fc28.x86_64


Expected results:

Upgrade to F28 


Additional info:

Virtualbox 5.2.10

Comment 1 Marek Blaha 2018-04-19 06:24:34 UTC
Looks like broken dependency:
on f28 xed requires libgspell-1.so.1, but gspell provides libgspell-1.so.2

Comment 2 leigh scott 2018-04-19 07:24:40 UTC
The fixed xed build was pushed to stable a month ago

https://bodhi.fedoraproject.org/updates/FEDORA-2018-5ebe0eb1f2

For some reason it didn't get pushed


xed                  x86_64                  1.6.4-0.2.20180309git3733860.fc28                    updates-testing                  2.4 M


Note You need to log in before you can comment on or make changes to this bug.