Bug 1569298 - Recurring meeting invites shown in wrong time zone
Summary: Recurring meeting invites shown in wrong time zone
Keywords:
Status: CLOSED DUPLICATE of bug 1547743
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-ews
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-19 00:59 UTC by Louis van Dyk
Modified: 2018-04-19 08:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-19 08:19:10 UTC
Type: Bug


Attachments (Terms of Use)

Description Louis van Dyk 2018-04-19 00:59:31 UTC
Description of problem:
I am in timezone GMT+2 (no DST).  My colleague is in India.  

If I am sent a one off meeting invite, the invite appears in my Evolution EWS calendar at the correct time.

If I am sent a recurring meeting invite, the invite appears in my Evolution EWS calendar at the SENDERS timezone time.  e.g. For a meeting at 14h00 India time, the meeting appears in MY (GMT+2) calendar as 14h00 as well, whereas it should be 10h30.  Now the odd thing is that if I open the message sent to the Exchange Inbox, where I can accept or deny the meeting, the correct local times are displayed.

In Outlook Web Access the meeting displays in the correct local times.


Version-Release number of selected component (if applicable):
evolution-3.26.6-1.fc27.x86_64
evolution-data-server-3.26.6-1.fc27.x86_64
evolution-data-server-langpacks-3.26.6-1.fc27.noarch
evolution-ews-3.26.6-1.fc27.x86_64
evolution-ews-langpacks-3.26.6-1.fc27.noarch
evolution-help-3.26.6-1.fc27.noarch
evolution-langpacks-3.26.6-1.fc27.noarch


How reproducible:
Always


Steps to Reproduce:
1. Receive a recurring meeting request from a user in another timezone.


Actual results:
Meeting displays in the calendar with their local time, not mine.


Expected results:
It should display in my local time.


Additional info:
I've stopped all Evolution processes and deleted all the files in ~/.cache/evolution/calendar but this didn't help.  After restarting and the calendar resyncing, the meeting again appeared in the wrong place.

Comment 1 Louis van Dyk 2018-04-19 01:25:28 UTC
I don't know if it's relevant, but my colleague is from another company.  We are on two separate Exchange instances, with a federation between them.  He is on Office 365, and ours is in-house.

Comment 2 Milan Crha 2018-04-19 08:19:10 UTC
Thanks for a bug report. This had been filled already as bug #1547743, thus I mark this as a duplicate of it.

*** This bug has been marked as a duplicate of bug 1547743 ***


Note You need to log in before you can comment on or make changes to this bug.