Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1569299 - Failed to get mapping info - virt-who - KeyError: 'config.network.dnsConfig.hostName'
Summary: Failed to get mapping info - virt-who - KeyError: 'config.network.dnsConfig.h...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-who
Version: 7.5
Hardware: All
OS: All
high
high
Target Milestone: pre-dev-freeze
: ---
Assignee: William Poteat
QA Contact: Eko
URL:
Whiteboard:
Depends On:
Blocks: 1573172
TreeView+ depends on / blocked
 
Reported: 2018-04-19 01:08 UTC by Waldirio M Pinheiro
Modified: 2021-06-10 15:53 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1573172 (view as bug list)
Environment:
Last Closed: 2018-10-30 10:47:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github candlepin virt-who pull 138 0 None closed 1569299: try/exception needed for hypervisor_id check 2020-07-13 03:43:33 UTC
Red Hat Knowledge Base (Solution) 3426901 0 None None None 2018-04-30 08:01:04 UTC
Red Hat Product Errata RHBA-2018:3169 0 None None None 2018-10-30 10:48:17 UTC

Description Waldirio M Pinheiro 2018-04-19 01:08:48 UTC
Description of problem:
Some customers are facing issue when virt-who is trying to retrieve the vCenter information. In all cases the issue started without any change/update on Satellite / Packages / Configuration side.

Version-Release number of selected component (if applicable):
virt-who-0.21.5-1.el7.noarch

How reproducible:
only on customer env. I'm trying to reproduce inhouse but without success.

Steps to Reproduce:
1.
2.
3.

Actual results:
---
2018-04-18 08:38:07,747 [virtwho.main ERROR] MainProcess(6836):Thread-2 @virt.py:run:388 - Thread 'virt-who-config-3' fails with exception:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/virtwho/virt/virt.py", line 379, in run
    self._run()
  File "/usr/lib/python2.7/site-packages/virtwho/virt/esx/esx.py", line 215, in _run
    assoc = self.getHostGuestMapping()
  File "/usr/lib/python2.7/site-packages/virtwho/virt/esx/esx.py", line 262, in getHostGuestMapping
    uuid = host['config.network.dnsConfig.hostName']
KeyError: 'config.network.dnsConfig.hostName'
---

Expected results:
No issues, virt-who collecting data normally from vCenter side.

Additional info:

Comment 9 Kevin Howell 2018-04-19 14:20:45 UTC
Given that we would like to handle by being more resilient in virt-who, changing product/component

Comment 23 William Poteat 2018-04-25 12:34:31 UTC
commit ec5e88d635d882a5d4a9b350ab5b5e1e93cb6782

Comment 26 William Poteat 2018-04-26 17:17:19 UTC
Business justification (customer impact; how would the defect impact customers’  business? why is it not possible to wait for a fix in Y-Stream?):

The defect causes ESX host reporting to fail. If any of the hosts in the network are missing the unique id as configured in the virt-who installation, then none of those hosts are reported to the server. In this scenario, the host/guest mappings are not captured and host-dependent subscriptions cannot be assigned to the guests. The Y-stream for 7.6 is not set to release until October.


How many customers are impacted by this defect?
The bugzilla for this has 6 customer issues attached. Any customer using VMWare, VSphere, or ESX may be affected.


When was the defect introduced in this major version of RHEL? Is it a regression?
This was introduced between 7.4 and 7.5 and it is a regression.


What is the minimal patch set to fix this bug? (link, git commit,...)
https://github.com/candlepin/virt-who/pull/138/commits/ec5e88d635d882a5d4a9b350ab5b5e1e93cb6782

Comment 31 William Poteat 2018-05-08 15:12:47 UTC
Please refer to the 7.5-z bug for the resolution in 7.5

https://bugzilla.redhat.com/show_bug.cgi?id=1573172

Comment 36 errata-xmlrpc 2018-10-30 10:47:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3169


Note You need to log in before you can comment on or make changes to this bug.