Bug 1569303 - [ovn]"dynamic_addresses" in table "Logical-Switch-Port" can't change along with "ipv6_prefix" and "subnet" automatically
Summary: [ovn]"dynamic_addresses" in table "Logical-Switch-Port" can't change along wi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openvswitch
Version: 7.5
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Mark Michelson
QA Contact: haidong li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-19 01:52 UTC by haidong li
Modified: 2020-01-14 22:41 UTC (History)
7 users (show)

Fixed In Version: openvswitch-2.9.0-71.el7fdn
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-02 17:54:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0014 0 None None None 2019-01-02 17:54:52 UTC

Description haidong li 2018-04-19 01:52:17 UTC
Description of problem:
"dynamic_addresses" in table "Logical-Switch-Port" can't change along with "ipv6_prefix" and "subnet" automatically

Version-Release number of selected component (if applicable):
ovs_version: "2.9.0"
3.10.0-862.el7.x86_64 

How reproducible:
everytime

Steps to Reproduce:
1.set the value of "other_config:ipv6_prefix" in "Logical-switch" table
2.get the "dynamic_addresses" in table "Logical-Switch-Port"
3.change the value of "other_config:ipv6_prefix"
4.the "dynamic_addresses" doesn't change
5. clear "dynamic_addresses" ,then get the new value.

the element "dynamic_addresses" in table "Logical-Switch-Port" can't change automatically after I change the value of element "other_config:ipv6_prefix" in "Logical-switch" table,unless I clear the "dynamic_addresses" manually.The "dynamic_addresses" should change along with "ipv6_prefix" and "subnet".

 [root@dell-per730-49 ovn]# ovn-nbctl lsp-get-addresses hv1_vm00_vnet1 00e:ad:01:00:01 dynamic
 [root@dell-per730-49 ovn]#
 root@dell-per730-49 ovn]#  ovn-nbctl  get Logical-switch ls_hv1_vm00 other_config
 {"ipv6_prefix"="2001b8:100::0", subnet="172.16.100.0/24"}
 [root@dell-per730-49 ovn]#
 [root@dell-per730-49 ovn]# ovn-nbctl get Logical-Switch-Port hv1_vm00_vnet1 dynamic_addresses
 "00e:ad:01:00:01 172.16.100.2 2001b8:100:0:2de:adff:fe01:1"
 [root@dell-per730-49 ovn]#  ovn-nbctl  set Logical-switch ls_hv1_vm00 other_config:ipv6_prefix=2002b8:100::0      
 [root@dell-per730-49 ovn]# ovn-nbctl get Logical-Switch-Port hv1_vm00_vnet1 dynamic_addresses
 "00e:ad:01:00:01 172.16.100.2 2001b8:100:0:2de:adff:fe01:1"                         
 [root@dell-per730-49 ovn]# ovn-nbctl get Logical-Switch-Port hv1_vm00_vnet1 dynamic_addresses
 "00e:ad:01:00:01 172.16.100.2 2001b8:100:0:2de:adff:fe01:1"
 [root@dell-per730-49 ovn]# ovn-nbctl clear Logical-Switch-Port hv1_vm00_vnet1 dynamic_addresses    
 [root@dell-per730-49 ovn]# ovn-nbctl get Logical-Switch-Port hv1_vm00_vnet1 dynamic_addresses
 "00e:ad:01:00:01 172.16.100.2 2002b8:100:0:2de:adff:fe01:1"                     

[root@dell-per730-49 ovn]# ovn-nbctl get Logical-Switch-Port hv1_vm00_vnet1 dynamic-addresses
"00e:ad:01:00:01 172.16.100.4 2001b8:100:0:2de:adff:fe01:1"
[root@dell-per730-49 ovn]#  ovn-nbctl  get Logical-switch ls_hv1_vm00 other_config
{"ipv6_prefix"="2001b8:100::0", subnet="172.16.100.2/24"}
[root@dell-per730-49 ovn]#  ovn-nbctl  set Logical-switch ls_hv1_vm00 other_config:subnet=200.16.100.2/24
[root@dell-per730-49 ovn]#  ovn-nbctl  get Logical-switch ls_hv1_vm00 other_config
{"ipv6_prefix"="2001b8:100::0", subnet="200.16.100.2/24"}
[root@dell-per730-49 ovn]# ovn-nbctl get Logical-Switch-Port hv1_vm00_vnet1 dynamic-addresses
"00e:ad:01:00:01 172.16.100.4 2001b8:100:0:2de:adff:fe01:1"
[root@dell-per730-49 ovn]# ovn-nbctl clear Logical-Switch-Port hv1_vm00_vnet1 dynamic-addresses
[root@dell-per730-49 ovn]# ovn-nbctl get Logical-Switch-Port hv1_vm00_vnet1 dynamic-addresses
"00e:ad:01:00:01 200.16.100.4 2001b8:100:0:2de:adff:fe01:1"
Actual results:


Expected results:


Additional info:

Comment 2 Mark Michelson 2018-08-03 14:55:05 UTC
This has been added to upstream OVS master and 2.10.

Comment 8 haidong li 2018-12-03 06:01:44 UTC
this issue is verified on the latest version:
[root@hp-dl388g8-19 ovn]# uname -a
Linux hp-dl388g8-19.rhts.eng.pek2.redhat.com 3.10.0-957.el7.x86_64 #1 SMP Thu Oct 4 20:48:51 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
[root@hp-dl388g8-19 ovn]# rpm -qa | grep openvswitch
openvswitch-2.9.0-81.el7fdp.x86_64
kernel-kernel-networking-openvswitch-ovn-1.0-108.noarch
openvswitch-ovn-common-2.9.0-81.el7fdp.x86_64
openvswitch-ovn-host-2.9.0-81.el7fdp.x86_64
openvswitch-selinux-extra-policy-1.0-8.el7fdp.noarch
openvswitch-ovn-central-2.9.0-81.el7fdp.x86_64
[root@hp-dl388g8-19 ovn]# 
[root@hp-dl388g8-19 ovn]# ovn-nbctl  set Logical-switch sw6 other_config:ipv6_prefix=2001:db8:100::0
[root@hp-dl388g8-19 ovn]# ovn-nbctl get Logical-Switch-Port p6 dynamic_addresses
"00:11:22:a8:64:03 192.168.100.2 2001:db8:100:0:211:22ff:fea8:6403"
[root@hp-dl388g8-19 ovn]# ovn-nbctl  set Logical-switch sw6 other_config:ipv6_prefix=2002:db8:100::0
[root@hp-dl388g8-19 ovn]# ovn-nbctl  get Logical-switch sw6 other_config
{"ipv6_prefix"="2002:db8:100::0", subnet="192.168.100.0/24"}
[root@hp-dl388g8-19 ovn]#
[root@hp-dl388g8-19 ovn]# ovn-nbctl get Logical-Switch-Port p6 dynamic_addresses
"00:11:22:a8:64:03 192.168.100.2 2002:db8:100:0:211:22ff:fea8:6403"
[root@hp-dl388g8-19 ovn]#
[root@hp-dl388g8-19 ovn]# ovn-nbctl  set Logical-switch sw6 other_config:ipv6_prefix=2003:db8:100::0
[root@hp-dl388g8-19 ovn]# ovn-nbctl  get Logical-switch sw6 other_config
{"ipv6_prefix"="2003:db8:100::0", subnet="192.168.100.0/24"}
[root@hp-dl388g8-19 ovn]# ovn-nbctl get Logical-Switch-Port p6 dynamic_addresses
"00:11:22:a8:64:03 192.168.100.2 2003:db8:100:0:211:22ff:fea8:6403"
[root@hp-dl388g8-19 ovn]#

Comment 12 errata-xmlrpc 2019-01-02 17:54:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0014


Note You need to log in before you can comment on or make changes to this bug.