Bug 1569345 - Need COMMITMENT from community for GPL Cure.
Summary: Need COMMITMENT from community for GPL Cure.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-19 06:18 UTC by Amar Tumballi
Modified: 2018-10-23 15:06 UTC (History)
3 users (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-23 15:06:59 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Amar Tumballi 2018-04-19 06:18:14 UTC
Description of problem:
Red Hat Inc., along with other industry leaders committed to enforcement statement.
https://www.redhat.com/en/blog/fostering-greater-open-source-development. 

GlusterFS, while we are committed to GPL (FreeSoftware licenses), would like to handle the GPL cure enforcement statement.

Version-Release number of selected component (if applicable):
GlusterFS project, master.

Expected results:
Gluster Project will be committed to this.

Additional info:
Patch posted @ https://review.gluster.org/19902

Comment 1 Worker Ant 2018-04-19 08:42:44 UTC
REVIEW: https://review.gluster.org/19902 (add COMMITMENT file as part of GPL cure) posted (#2) for review on master by Amar Tumballi

Comment 2 Worker Ant 2018-05-25 08:40:41 UTC
COMMIT: https://review.gluster.org/19902 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- add COMMITMENT file as part of GPL cure

This is part of more broader commitment Red Hat along with
IBM, Google, and Facebook did in November 2017.

More on this can be found in the blog @
https://www.redhat.com/en/blog/fostering-greater-open-source-development &
https://www.redhat.com/en/about/gplv3-enforcement-statement

fixes: bz#1569345
Change-Id: Ia78023540ab587ebe14048a67413029be309413d
Signed-off-by: Amar Tumballi <amarts@redhat.com>

Comment 3 Shyamsundar 2018-10-23 15:06:59 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.