Bug 1569399 - glusterfsd should be able to start without any other arguments than a single volfile.
Summary: glusterfsd should be able to start without any other arguments than a single ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Amar Tumballi
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-19 08:39 UTC by Amar Tumballi
Modified: 2018-10-23 15:07 UTC (History)
1 user (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-23 15:07:33 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Amar Tumballi 2018-04-19 08:39:06 UTC
Description of problem:

Other than for brick-multiplexing process, there is no reason for glusterfs to have any other mandatory cmd-line-args, to start the process. Specially, when we have a local volfile.

Today, if I do start a server process (one with protocol/server volume is present) with just a local volfile, the process crashes.

Version-Release number of selected component (if applicable):
master

How reproducible:
100%

Steps to Reproduce:
1. glusterd; volume create (1 brick); killall glusterd;
2. glusterfsd -f /var/lib/glusterd/vols/<volname>/<volname>.<hostname>-brick-path.vol


Actual results:
process crashes

Expected results:
shouldn't crash

Comment 1 Worker Ant 2018-04-19 08:41:46 UTC
REVIEW: https://review.gluster.org/19893 (protocol/server: don't assume there would be a volfile id) posted (#5) for review on master by Amar Tumballi

Comment 2 Worker Ant 2018-05-08 21:16:51 UTC
COMMIT: https://review.gluster.org/19893 committed in master by "Jeff Darcy" <jeff@pl.atyp.us> with a commit message- protocol/server: don't assume there would be a volfile id

Earlier glusterfs never had an assumption someone would start it with
right arguments, and brick processes would be spawned by a management
layer. It just assume the role based on the volfile. Other than
volfile, no other arguments should be technically mandatory for
working of glusterfs. With this patch, that assumption holds true.

Updates: github issue # 352

A note on why this particular issue for this basic sanity?

As per the design of thin-arbiter/tie-breaker, it can be started
independently on any machine, without need of glusterd. So, similar
to 'glusterd', we should be able to spawn a process with any translator
without options/volume id etc.

fixes: bz#1569399
Change-Id: I5c0650fe0bfde35ad94ccba60e63f6cdcd1ae5ff
Signed-off-by: Amar Tumballi <amarts@redhat.com>

Comment 3 Shyamsundar 2018-10-23 15:07:33 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.