Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1569414 - [RFE] Kickstart template for VDO volumes
Summary: [RFE] Kickstart template for VDO volumes
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning Templates
Version: 6.3.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On: 1569563
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-19 09:01 UTC by Shivdutt Bharadwaj
Modified: 2021-06-10 15:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1569563 (view as bug list)
Environment:
Last Closed: 2019-11-04 14:02:47 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Shivdutt Bharadwaj 2018-04-19 09:01:07 UTC
Description of problem: Kickstart template for VDO volumes needed as RHEL 7.5 ships vdo. Current kickstart file is only for LVM on physical or virtual disks.


Version-Release number of selected component (if applicable): satellite 6.3.1 / RHEL 7.5


How reproducible: always


Steps to Reproduce:
1. Go to hosts > provisioning templates 
2. No kickstart template for vdo type of volumes.
3.

Actual results: No kickstart template for vdo present


Expected results: Need kickstart template for vdo present


Additional info:

Comment 1 ir. Jan Gerrit Kootstra 2018-04-19 09:08:38 UTC
If you need a customer to beta test this feature. I have a demo Satellite 6.3.1 that can be used.

Comment 2 Marek Hulan 2018-04-19 13:49:13 UTC
I haven't found any documentation on Anaconda supporting this as a kickstart parameter. In theory you could modify your kickstart %package to install vdo utilities and do "vdo create ..." in %post. But to get "built-in" support, we'd need to have the support in Anaconda first. I'll open a blocker issue in a minute.

Comment 3 Bryan Kearney 2019-11-04 14:02:47 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.