Bug 1569420 - Failed to execute Ansible host-deploy role
Summary: Failed to execute Ansible host-deploy role
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Host-Deploy
Version: 4.2.3
Hardware: All
OS: Linux
high
high
Target Milestone: ovirt-4.2.3
: ---
Assignee: Sahina Bose
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-19 09:19 UTC by Petr Balogh
Modified: 2018-05-10 06:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 06:27:05 UTC
oVirt Team: Gluster
rule-engine: ovirt-4.2+
rule-engine: blocker+
sabose: devel_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90468 0 master MERGED gluster: Fixing ansible playbook issue with abs filter 2020-06-16 12:53:37 UTC
oVirt gerrit 90471 0 ovirt-engine-4.2 MERGED gluster: Fixing ansible playbook issue with abs filter 2020-06-16 12:53:38 UTC

Description Petr Balogh 2018-04-19 09:19:10 UTC
Description of problem:
When deploying new host in cluster with enabled Gluster we are failing with error:
2018-04-19 01:50:21,725 p=10890 u=ovirt |  TASK [hc-gluster-cgroups : Set CPU quota] **************************************
2018-04-19 01:50:21,741 p=10890 u=ovirt |  [DEPRECATION WARNING]: Using tests as filters is deprecated. Instead of using 
`result|abs` instead use `result is abs`. This feature will be removed in 
version 2.9. Deprecation warnings can be disabled by setting 
deprecation_warnings=False in ansible.cfg.
2018-04-19 01:50:21,756 p=10890 u=ovirt |  An exception occurred during task execution. To see the full traceback, use -vvv. The error was: AttributeError: 'int' object has no attribute 'startswith'
2018-04-19 01:50:21,756 p=10890 u=ovirt |  fatal: [host.xx.xx.com]: FAILED! => {}



Version-Release number of selected component (if applicable):
rhv-4.2.3-2
Host: RHVH-4.2-20180404.0

How reproducible:


Steps to Reproduce:
1. Install engine
2. Create cluster with Enable Gluster Service
3. Add host

Actual results:
Failing in deployment with mentioned error


Expected results:
Deployed host.

Additional info:

Comment 3 Sahina Bose 2018-04-19 10:01:24 UTC
This seems to be an issue with the abs filter in ansible 2.5 tracked at https://github.com/ansible/ansible/issues/37856 and fixed in 2.5.1 as per the github issue.

To unblock removing abs as the int check should suffice.

Comment 4 Sandro Bonazzola 2018-04-19 10:10:06 UTC
Please note ansible 2.5.1 has been released.
It's in testing for EPEL: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-ad971a0926

Comment 5 SATHEESARAN 2018-05-09 14:11:43 UTC
Tested with RHV 4.2.3-6 with the following steps:

1. Created a new RHV 4.2 cluster
2. Added a RHVH node to cluster
3. Added one more node to the cluster

All the nodes added the cluster become operational

Comment 6 Sandro Bonazzola 2018-05-10 06:27:05 UTC
This bugzilla is included in oVirt 4.2.3 release, published on May 4th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.