Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1569432 - oc status should advise oc status --suggest instead of -v depreciated
Summary: oc status should advise oc status --suggest instead of -v depreciated
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.11.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-19 09:31 UTC by Xingxing Xia
Modified: 2019-04-11 05:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-11 05:38:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0636 0 None None None 2019-04-11 05:38:28 UTC

Description Xingxing Xia 2018-04-19 09:31:26 UTC
Description of problem:
oc status should advise oc status --suggest instead of -v depreciated

Version-Release number of selected component (if applicable):
v3.10.0-0.22.0

How reproducible:
Always

Steps to Reproduce:
1. $ oc new-app openshift/hello-openshift
2. $ oc status

Actual results:
2. It shows:
..., use 'oc status -v' to see details

Expected results:
2. Should advise oc status --suggest instead of -v depreciated (oc status -v prompts it depreciated)

Additional info:

Comment 2 Maciej Szulik 2019-02-27 21:49:32 UTC
This was fixed in 3.11, moving to qa.

Comment 3 zhou ying 2019-02-28 03:33:54 UTC
Confirmed with latest 3.11 version, the issue has fixed:
[root@dhcp-140-138 home]# oc status
In project zhouy on server https://ec2-3-81-91-139.compute-1.amazonaws.com:8443

svc/ruby-ex - 172.30.80.79:8080
  dc/ruby-ex deploys istag/ruby-ex:latest <-
    bc/ruby-ex source builds https://github.com/sclorg/ruby-ex.git on istag/ruby-25-centos7:latest 
      build #1 running for 7 seconds - c00ecd7: Merge pull request #25 from pvalena/master (Honza Horak <hhorak@redhat.com>)
    deployment #1 waiting on image or update


2 infos identified, use 'oc status --suggest' to see details.
[root@dhcp-140-138 home]# oc version
oc v3.11.87
kubernetes v1.11.0+d4cacc0
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://ec2-3-81-91-139.compute-1.amazonaws.com:8443
openshift v3.11.82
kubernetes v1.11.0+d4cacc0

Comment 5 errata-xmlrpc 2019-04-11 05:38:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0636


Note You need to log in before you can comment on or make changes to this bug.