Bug 1569464 - [subscription-manager] Tier 0 Localization
Summary: [subscription-manager] Tier 0 Localization
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.6
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: 7.6
Assignee: candlepin-bugs
QA Contact: Engineering Localization bugs mailing list
URL:
Whiteboard:
: 1625425 (view as bug list)
Depends On:
Blocks: 1549951
TreeView+ depends on / blocked
 
Reported: 2018-04-19 10:16 UTC by Ludek Janda
Modified: 2018-10-30 10:37 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:36:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3153 None None None 2018-10-30 10:37:12 UTC

Description Ludek Janda 2018-04-19 10:16:32 UTC
THIS IS A PLACEHOLDER TICKET FOR A POTENTIAL L10N WORK IN RHEL 7.6

Your package is on the list of the top priority packages for RHEL 7 localization https://mojo.redhat.com/docs/DOC-1145886

After String Freeze date (https://pp.engineering.redhat.com/pp/schedules/rhel-7-6):

- the amount of translated strings will be checked for the supported languages (Japanese, all other languages would need to be requested by RHEL 7 PM).

- all untranslated/marked for Translation strings in those languages (Japanese atm) are going to be localized and you'll receive a localization patch (in form of a PO file or you'll be given access to our internal Zanata)

- in case no untranslated strings are detected in concerned languages or no internal or other localization work out of scope and policy of Red Hat Localization team happened, this placeholder ticket may be closed.

- during translation work, the placeholder BZ will be assigned to l10n PgM or respective Translator.

- post translation and commit, the placeholder BZ should be assigned to respective package maintainer(developer) by l10n PgM or respective translator with a note marking end of translation work and a request to rebuild the package to include latest translated strings.

- after your package is rebuilt with the localization patch, the ticket moves to ON_QA and the i18n QE and l10n QA will follow to check sanity and coherency of translated strings. 

Version-Release number of selected component (if applicable):7.6

Expected results:
100% translated strings in Japanese (+ other language in case of specific RHEL 7 PM specification)

Additional info: n/a

Comment 9 Chris Snyder 2018-09-07 20:33:20 UTC
*** Bug 1625425 has been marked as a duplicate of this bug. ***

Comment 10 John Sefler 2018-09-10 15:09:55 UTC
Moving to VERIFIED...

[root@jsefler-rhel7 ~]# rpm -q subscription-manager
subscription-manager-1.21.10-2.el7.x86_64
[root@jsefler-rhel7 ~]# 
[root@jsefler-rhel7 ~]# for L in `rpm -ql subscription-manager | grep rhsm.mo | egrep "de|es|fr|it|ja|ko|pt_BR|ru|zh_CN|zh_TW"`; do echo ""; echo "counting the translated msgid's in LANG file '$L'..."; msgunfmt --no-wrap $L | egrep ^msgid | wc -l; done;

counting the translated msgid's in LANG file '/usr/share/locale/de/LC_MESSAGES/rhsm.mo'...
1046

counting the translated msgid's in LANG file '/usr/share/locale/es/LC_MESSAGES/rhsm.mo'...
1046

counting the translated msgid's in LANG file '/usr/share/locale/fr/LC_MESSAGES/rhsm.mo'...
1051

counting the translated msgid's in LANG file '/usr/share/locale/it/LC_MESSAGES/rhsm.mo'...
1046

counting the translated msgid's in LANG file '/usr/share/locale/ja/LC_MESSAGES/rhsm.mo'...
1051

counting the translated msgid's in LANG file '/usr/share/locale/ko/LC_MESSAGES/rhsm.mo'...
1051

counting the translated msgid's in LANG file '/usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo'...
1046

counting the translated msgid's in LANG file '/usr/share/locale/ru/LC_MESSAGES/rhsm.mo'...
1046

counting the translated msgid's in LANG file '/usr/share/locale/zh_CN/LC_MESSAGES/rhsm.mo'...
1051

counting the translated msgid's in LANG file '/usr/share/locale/zh_TW/LC_MESSAGES/rhsm.mo'...
1046
[root@jsefler-rhel7 ~]# 

As planned for rhel-7.6 in comment 0, Japanese is 100% translated at 1051 messages.  Four Langs [ja] [fr] [zh_CN] [ko] are actually 100% translated.  The remaining untranslated langs will wait until rhel-7.7 for the next translation campaign.  Bugs opened on untranslated strings will be deferred.

Comment 13 errata-xmlrpc 2018-10-30 10:36:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3153


Note You need to log in before you can comment on or make changes to this bug.