Bug 1569542 - lm_sensors: update required to support AMD Family 17h
Summary: lm_sensors: update required to support AMD Family 17h
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lm_sensors
Version: 7.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Ondřej Lysoněk
QA Contact: Rachel Sibley
URL:
Whiteboard:
Depends On:
Blocks: 1507957 1537631 1609081
TreeView+ depends on / blocked
 
Reported: 2018-04-19 13:14 UTC by David Arcari
Modified: 2018-10-30 07:57 UTC (History)
5 users (show)

Fixed In Version: lm_sensors-3.4.0-5.20160601gitf9185e5.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 07:56:57 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch (879 bytes, patch)
2018-04-20 14:27 UTC, Ondřej Lysoněk
no flags Details | Diff
patch 2 (922 bytes, patch)
2018-05-15 09:05 UTC, Ondřej Lysoněk
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1446653 1 None None None 2021-01-20 06:05:38 UTC
Red Hat Product Errata RHEA-2018:3051 0 None None None 2018-10-30 07:57:06 UTC

Internal Links: 1446653

Description David Arcari 2018-04-19 13:14:22 UTC
Description of problem:

The RHEL version of sensors-detect does not have support for AMD Family17h.  This support is available upstream.


Version-Release number of selected component (if applicable):

RHEL7.5


How reproducible:

100%


Steps to Reproduce:
1. Run sensors-detect


Actual results:

<snip>
AMD K8 thermal sensors...                                   No
AMD Family 10h thermal sensors...                           No
AMD Family 11h thermal sensors...                           No
AMD Family 12h and 14h thermal sensors...                   No
AMD Family 15h thermal sensors...                           No
AMD Family 16h thermal sensors...                           No
AMD Family 15h power sensors...                             No
AMD Family 16h power sensors...                             No
Intel digital thermal sensor...                             No
<snip>

Expected results:

AMD Family 10h thermal sensors...                           No
AMD Family 11h thermal sensors...                           No
AMD Family 12h and 14h thermal sensors...                   No
AMD Family 15h thermal sensors...                           No
AMD Family 16h thermal sensors...                           No
AMD Family 17h thermal sensors...                           Success!
    (driver `k10temp')
AMD Family 15h power sensors...                             No
AMD Family 16h power sensors...                             No

Comment 3 Ondřej Lysoněk 2018-04-20 14:27:13 UTC
Created attachment 1424524 [details]
patch

Comment 5 Rachel Sibley 2018-04-20 14:35:15 UTC
Ondrej, yes I have capacity, setting qa_ack+

Comment 7 Ondřej Lysoněk 2018-05-15 09:05:14 UTC
Created attachment 1436738 [details]
patch 2

Comment 12 errata-xmlrpc 2018-10-30 07:56:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:3051


Note You need to log in before you can comment on or make changes to this bug.