Bug 1569564 - 'rpm -V java-1.8.0-openjdk-headless-1.8.0.161-2.b14.el7.x86_64' fails
Summary: 'rpm -V java-1.8.0-openjdk-headless-1.8.0.161-2.b14.el7.x86_64' fails
Keywords:
Status: CLOSED DUPLICATE of bug 1579446
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: java-1.8.0-openjdk
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: jiri vanek
QA Contact: zzambers
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-19 13:55 UTC by Justin Pierce
Modified: 2018-06-05 17:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-05 17:17:48 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Justin Pierce 2018-04-19 13:55:10 UTC
Description of problem:
rpm verification of java-1.8.0-openjdk-headless-1.8.0.161-2.b14.el7.x86_64 fails due to:
.M.......  g /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.161-2.b14.el7.x86_64/jre/lib/amd64/server/classes.jsa

Version-Release number of selected component (if applicable):
1.8.0

How reproducible:
100%

Steps to Reproduce:
1. rpm -V the RPM after install

Additional info:
This breaking multiple OpenShift container image builds. 

From an email thread with jvanek
-----
M in verify stands for Mode. That iisue is casued by permissions.
jsa is generated as 666
in previous rpm.rpm, ghost, marked as 644 changed jsa file to 644
in new rpm.rpm,  ghost files attributes ar enot touched during rpm build, so js fiel keeps the 666, as was generated.
However, verify still counts wht attr attribute.

Fix is to remove attr attribute from ghosted jsa file or to chnage attr to 666. IMho the second is better.
-----

Comment 3 Scott Dodson 2018-06-05 17:16:26 UTC
This is the same problem as Bug 1551973, not duping because of the different release 7.5 vs 7.5 though.

Comment 4 Scott Dodson 2018-06-05 17:17:15 UTC
Sorry, I mean bug 1579446

Comment 5 Scott Dodson 2018-06-05 17:17:48 UTC

*** This bug has been marked as a duplicate of bug 1579446 ***


Note You need to log in before you can comment on or make changes to this bug.