Bug 1569579 - OVN network manager No route to host - <engine_IP>:8774 (Errno::EHOSTUNREACH)
Summary: OVN network manager No route to host - <engine_IP>:8774 (Errno::EHOSTUNREACH)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.9.3
Assignee: Gregg Tanzillo
QA Contact: Radim Hrazdil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-19 14:22 UTC by Radim Hrazdil
Modified: 2018-04-23 13:59 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-23 10:19:31 UTC
Category: ---
Cloudforms Team: RHEVM
Target Upstream Version:


Attachments (Terms of Use)
evm.log (1017 bytes, text/plain)
2018-04-19 14:22 UTC, Radim Hrazdil
no flags Details

Description Radim Hrazdil 2018-04-19 14:22:19 UTC
Created attachment 1424126 [details]
evm.log

Description of problem:
After updating CFME from 5.9.1 to 5.9.2.2, refreshing OVN network manager fails on:

Error - Less Than A Minute Ago
No route to host - connect(2) for <engine_ip>:8774 (Errno::EHOSTUNREACH)

Network entities created in cfme will appear correctly in RHV provider, but will not be synced in CFME appliance (won't appear in cfme).
Checked that using clean CFME version 5.9.2.0 and adding the same rhv provider into it, refresh succeeds and all network entities are synced correctly.

Port 8774 is indeed not open on the RHV provider. The OVN network manager listens on port 9696 by default. 

Version-Release number of selected component (if applicable):
CFME 5.9.2.2

RHV 4.2.2.5-0.1.el7
ovirt-provider-ovn-1.2.9-1.el7ev.noarch
openvswitch-ovn-common-2.9.0-1.el7fdp.x86_64
openvswitch-ovn-central-2.9.0-1.el7fdp.x86_64


How reproducible:
100%

Steps to Reproduce:
1. 
2.
3.

Actual results:
OVN network manager fails to refresh

Expected results:
refresh should succeed

Additional info:

Comment 2 Radim Hrazdil 2018-04-23 10:19:31 UTC
Turns out this is not issue in CFME and it is related to this patch [1]. 

In order to fix the issue, ovirt ovn provider on RHV machine needs to be updated to version ovirt-provider-ovn-1.2.10-1.

Closing as not a bug.


[1] https://gerrit.ovirt.org/#/c/89564/2/provider/ovirt_provider_config.py


Note You need to log in before you can comment on or make changes to this bug.