Bug 1569627 - openshift-ansible aws provisioning - ELB instance port is ALWAYS assigned to the openshift master api port.
Summary: openshift-ansible aws provisioning - ELB instance port is ALWAYS assigned to ...
Keywords:
Status: CLOSED DUPLICATE of bug 1569680
Alias: None
Product: OKD
Classification: Red Hat
Component: Installer
Version: 3.x
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-19 15:37 UTC by Matt Woodson
Modified: 2018-08-23 18:23 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-23 18:23:13 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Matt Woodson 2018-04-19 15:37:03 UTC
Description of problem:

When setting up an ELB in openshift-ansible provisioning, the "instance port" (the port that the ELB listens on for incoming connections) is by default, set to the openshift api port.

Code can be found here (there are other instances in the same data structure):

https://github.com/openshift/openshift-ansible/blob/master/roles/openshift_aws/defaults/main.yml#L71


What this means is that if the api port is set to 8443, by default, the ELB will only listen on 8443. 

Version-Release number of selected component (if applicable):

openshift-ansible 3.9, 3.10


Expected results:

I would expect to be able to have the ELB listen on port 443 and forward to the server on 8443.


Additional info:

To work around this I am copying the entire variable "openshift_aws_elb_dict" and setting it up the ports that I want.

Comment 1 Scott Dodson 2018-08-23 18:23:13 UTC

*** This bug has been marked as a duplicate of bug 1569680 ***


Note You need to log in before you can comment on or make changes to this bug.