Bug 1569684 - etcd-docker build for 7.5.1
Summary: etcd-docker build for 7.5.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: etcd-container
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Avesh Agarwal
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-19 19:32 UTC by Avesh Agarwal
Modified: 2018-05-14 17:14 UTC (History)
1 user (show)

Fixed In Version: etcd-docker-3.2.18-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-14 17:14:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1440 0 None None None 2018-05-14 17:14:29 UTC

Description Avesh Agarwal 2018-04-19 19:32:01 UTC
Description of problem:
etcd-docker build for 7.5.1

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 Joy Pu 2018-05-11 05:21:42 UTC
Test the image with following cases:
1. Start etcd container Start the container in following ways
 a) Start etcd container directly
 b) sharing ports with host
 c) sharing network with host
2. Key value test for etcd Star etcd container and sharing network with host and do following tests:
 1) Check etcd version info via curl/etcdctl
 2) Set/get/update/remove key value via curl/etcdctl
 3) Watch key value via curl/etcdctl
 4) TTL test for key value
3.cluster test Set up a etcd cluster with three node
 a) setup with static method
 b) setup with etcd discovery and shared network with host
 c) setup with etcd discovery and shared network without host
4. Etcd server can be access with https
5. Test etcd with kubernetes and flanneld
6. Etcd container running in atomic host.

They are all passed. So set this to verified.

Comment 7 errata-xmlrpc 2018-05-14 17:14:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1440


Note You need to log in before you can comment on or make changes to this bug.