Bug 1569689 - MDS rolling-upgrade process needs to be changed to follow new recommendations
Summary: MDS rolling-upgrade process needs to be changed to follow new recommendations
Status: ASSIGNED
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.0
Hardware: All
OS: All
high
high
Target Milestone: z1
: 3.3
Assignee: Ram Raja
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-19 19:49 UTC by Patrick Donnelly
Modified: 2019-07-14 02:26 UTC (History)
13 users (show)

(edit)
Clone Of:
(edit)
Last Closed:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github ceph ceph-ansible pull 2549 None None None 2018-04-30 04:14 UTC
Red Hat Bugzilla 1550026 None VERIFIED upgrade to 12.2.3 will cause MDSs to fail during upgrade 2019-07-17 08:34 UTC

Internal Trackers: 1550026

Description Patrick Donnelly 2018-04-19 19:49:26 UTC
Description of problem:

The MDS rolling-upgrade procedure should follow the guide documented in this PR:

https://github.com/ceph/ceph/pull/21263/files

Note, the current upgrade procedure in the master branch is for Mimic only.

Comment 6 Ken Dreyer (Red Hat) 2018-05-30 14:08:24 UTC
https://github.com/ceph/ceph-ansible/pull/2549 still in progress upstream. Re-targeting this BZ to a later product release.

Comment 7 Harish NV Rao 2018-09-18 14:13:10 UTC
(In reply to Ken Dreyer (Red Hat) from comment #6)
> https://github.com/ceph/ceph-ansible/pull/2549 still in progress upstream.
> Re-targeting this BZ to a later product release.

@Ken, looks like above is still in progress. Can you please check and move this BZ out of z1 if it's not going to be fixed in 3.1z1?


Note You need to log in before you can comment on or make changes to this bug.