Bug 1569695 - The sum of listed installed and available packages' number. does not match all packages' number.
Summary: The sum of listed installed and available packages' number. does not match al...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 28
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-19 20:05 UTC by ricky.tigg
Modified: 2018-04-24 09:51 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-24 07:10:35 UTC
Type: Bug


Attachments (Terms of Use)

Description ricky.tigg 2018-04-19 20:05:01 UTC
Description of problem: the sum of listed installed and available packages numbers does not match the value as output for all packages.

Version-Release number of component: dnf.noarch 2.7.5-12.fc28 @updates-testing

Steps to Reproduce in terminal:
1. $ dnf list all | wc -l
2. $ dnf list installed | wc -l
3. $ dnf list available | wc -l

Actual results: Assume outputs resulting from commands illustrated in steps 1., 2., 3,  are respectively represented by x, y, z. Currently x > y + z;  non-equality would suggest that x might take in account duplicates. Since it's not the case I suspect an issue.

Expected results: x = y + z; Requirement in order for each one to be reliable.

Additional info:
$ dnf check --duplicates (No output). Confirmation by running:
# dnf remove --duplicates
Error: No duplicated packages found for removal.

Comment 1 Martin Hatina 2018-04-24 07:10:35 UTC
Some modules are disabled and possibly without default stream, which results into packages not being available. That's why 'all != installed + available'.

Comment 2 ricky.tigg 2018-04-24 09:51:02 UTC
These are aspects that could not have been guessed. Now I know.


Note You need to log in before you can comment on or make changes to this bug.