Bug 1569795 - FFU: OSP12->13 yum update fails with on overcloud nodes with python-networking-cisco dependency
Summary: FFU: OSP12->13 yum update fails with on overcloud nodes with python-networkin...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-cisco
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: RHOS Maint
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-20 01:18 UTC by Marius Cornea
Modified: 2018-06-27 13:53 UTC (History)
9 users (show)

Fixed In Version: python-networking-cisco-5.5.0-1.1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:52:02 UTC
Target Upstream Version:


Attachments (Terms of Use)
yum.log (65.34 KB, text/plain)
2018-04-20 01:18 UTC, Marius Cornea
no flags Details


Links
System ID Private Priority Status Summary Last Updated
RDO 12102 0 None rpm-master: MERGED openstack/networking-cisco-distgit: Drop BR/Req on python-neutron-tests (Ib0596e73e039a9ae909aa74122e209a1bc3febe6) 2018-04-24 14:08:56 UTC
Red Hat Product Errata RHEA-2018:2086 0 None None None 2018-06-27 13:53:11 UTC

Description Marius Cornea 2018-04-20 01:18:04 UTC
Created attachment 1424333 [details]
yum.log

Description of problem:

FFU: OSP12->13 yum update fails with on overcloud nodes with python-networking-cisco dependency:

Error: Package: 1:python-networking-cisco-5.5.0-1.el7ost.noarch (@rhos-10.0-signed)
           Requires: python-neutron-tests
           Removing: 1:python-neutron-tests-11.0.2-1.el7ost.noarch (@rhelosp-12.0-puddle)
               python-neutron-tests = 1:11.0.2-1.el7ost
           Obsoleted By: python2-neutron-tests-tempest-0.0.1-0.20180414005434.cca1528.el7ost.noarch (rhelosp-13.0-puddle)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP10
2. Run through the FFU procedure to OSP13

Actual results:
yum update fails when upgrading controller nodes to OSP13.

Expected results:
yum update doesn't fail.

Additional info:
Attaching full yum.log output

Comment 1 Jose Luis Franco 2018-04-23 09:31:41 UTC
Wasn't this addressed in this other BZ https://bugzilla.redhat.com/show_bug.cgi?id=1549845 ? Seems like the same issue is still happening.

Comment 2 Carlos Camacho 2018-04-23 13:48:13 UTC
Not duplicated, missing backport @ https://review.rdoproject.org/r/#/c/12102/

Comment 11 errata-xmlrpc 2018-06-27 13:52:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.