Bug 1569826 - No environment variables to control if NPD to be installed during cluster deployment
Summary: No environment variables to control if NPD to be installed during cluster dep...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Joel Smith
QA Contact: Weinan Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-20 03:33 UTC by Weinan Liu
Modified: 2018-07-30 19:13 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1580212 (view as bug list)
Environment:
Last Closed: 2018-07-30 19:13:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:13:51 UTC

Description Weinan Liu 2018-04-20 03:33:25 UTC
Description of problem:
No environment variables to control if NPD to be installed during cluster deployment.
 Currently we have to run an additional command to make NPD running on OCP cluster like this:
ansible-playbook -vvv -i qe-inventory-host-file playbooks/openshift-node-problem-detector/config.yml

Can we put openshift-node-problem-detector in playbooks/common/private/components.yml to use a switch env variables to control if it is to be installed?

How reproducible:
always

Steps to Reproduce:
(As Description)

Actual results:
No environment variables to control if NPD to be installed during cluster deployment

Expected results:
We have environment variables to control if NPD to be installed during cluster deployment

Additional info:
[root@qe-weinliu310-master-etcd-1 ~]# oc version
oc v3.10.0-0.21.0
kubernetes v1.10.0+b81c8f8
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://qe-weinliu310-master-etcd-1:8443
openshift v3.10.0-0.21.0
kubernetes v1.10.0+b81c8f8

[root@qe-weinliu310-master-etcd-1 ~]# uname -a
Linux qe-weinliu310-master-etcd-1 3.10.0-862.el7.x86_64 #1 SMP Wed Mar 21 18:14:51 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux
[root@qe-weinliu310-master-etcd-1 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.5 (Maipo)

Comment 1 Joel Smith 2018-04-21 21:46:45 UTC
Thanks for filing this bug; it's a great idea to add it to the installer.

I've opened this PR and I'll mark this bug MODIFIED as soon as it merges:

https://github.com/openshift/openshift-ansible/pull/8079

Comment 2 Jan Chaloupka 2018-04-26 05:58:36 UTC
Merged upstream

Comment 4 Weinan Liu 2018-05-16 03:30:05 UTC
Issue verified to be fixed


LAUNCHER_VARS
  openshift_node_problem_detector_install: true
  openshift_node_problem_detector_image_prefix: "registry.<private>:443/openshift3/ose-"
  openshift_node_problem_detector_image_version: v3.10.0

Comment 6 errata-xmlrpc 2018-07-30 19:13:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.