Bug 1569850 - migration fails using Vdsm 4.30.z on cluster <= 4.1 for VMs with payload device
Summary: migration fails using Vdsm 4.30.z on cluster <= 4.1 for VMs with payload device
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: vdsm
Classification: oVirt
Component: Core
Version: 4.30.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.2.3
: ---
Assignee: Francesco Romani
QA Contact: Israel Pinto
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-20 06:22 UTC by Francesco Romani
Modified: 2018-05-10 06:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 06:31:11 UTC
oVirt Team: Virt
rule-engine: ovirt-4.2+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90486 0 ovirt-4.2 MERGED virt: properly store Drive specParams 2018-04-20 09:02:17 UTC

Description Francesco Romani 2018-04-20 06:22:49 UTC
Description of problem:
VMs with payload device (sysprep, cloud init) can no longer properly migrate if 
clusters <= 4.1 are upgraded with Vdsm >= 4.2, while still retaining the old clusterLevel.


Version-Release number of selected component (if applicable):
Any Vdsm >= 4.2 in cluster <= 4.1

How reproducible:
100%

Steps to Reproduce:
1. Prepare a <= 4.1 oVirt environment, upgrade Vdsm to 4.2.2 in a cluster
2. Run a VM with either sysprep or cloud-init
3. Suspend the VM
4. Try to migrate (or suspend again) the same VM

Actual results:
The last migration/suspension will fail

Expected results:
Migration/suspension should succeed as usual

Additional info:
VMs without payload devices are not affected.
Vdsm fail to properly store the information needed to rebuild the payload device past the first time, so after the first time the VM goes away (e.g. suspension, migration or even Vdsm restart), it can no longer rebuild it, and the corresponding VM device (e.g. cdrom) will be dangling, leading to migration failures.

Comment 1 Francesco Romani 2018-04-20 06:24:20 UTC
no doc_text: this should "just work" and should not have user-visible consequences. Aka the behaviour should not have changed.

Comment 2 Israel Pinto 2018-05-02 11:56:06 UTC
Verify with:
Engine version:4.2.3.3-0.1.el7

Steps:
1. Create VM
2. Run VM with cloud init on 4.1 host in 4.1 cluster on rhevm 4.2.3 
3. Check that VM has payload on the host.
CASE 1: Migrate to 4.2 host 
CASE 2: Suspend VM and Resume the VM on 4.2 host. (host on cluster 4.1)

PASS 
Payload exist on 4.2 host for both cases

Comment 3 Sandro Bonazzola 2018-05-10 06:31:11 UTC
This bugzilla is included in oVirt 4.2.3 release, published on May 4th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.