Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1569872 - Avoid busy loop on reconfig failure
Summary: Avoid busy loop on reconfig failure
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tcmu-runner
Version: cns-3.10
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: CNS 3.10
Assignee: Prasanna Kumar Kalever
QA Contact: Sweta Anandpara
URL:
Whiteboard:
Depends On:
Blocks: 1568861
TreeView+ depends on / blocked
 
Reported: 2018-04-20 07:50 UTC by Prasanna Kumar Kalever
Modified: 2018-09-12 09:26 UTC (History)
6 users (show)

Fixed In Version: tcmu-runner-1.2.0-19.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-12 09:25:34 UTC
Target Upstream Version:


Attachments (Terms of Use)
gdb logs (8.73 KB, text/plain)
2018-08-02 06:00 UTC, Sweta Anandpara
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2691 0 None None None 2018-09-12 09:26:41 UTC

Description Prasanna Kumar Kalever 2018-04-20 07:50:15 UTC
Description of problem:

when trying to reopen the device, if glfs open device fail,wait for a 1 sec and then try to open device again to avoid busy loop.

This is more of a regression introduced while we are trying to fix resize partial failures with

commit ac449d5ce9a0fd39f9b1b9e84828b434ef166aeb
Author: Xiubo Li <xiubli@redhat.com>
Date:   Mon Mar 12 16:45:33 2018 -0400

    glfs: reopen on connection lost
    
    Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>
    Signed-off-by: Xiubo Li <xiubli@redhat.com>

Comment 8 Sweta Anandpara 2018-08-02 06:00:58 UTC
Created attachment 1472264 [details]
gdb logs

Comment 10 errata-xmlrpc 2018-09-12 09:25:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2691


Note You need to log in before you can comment on or make changes to this bug.