Bug 1569895 - control plane install failed if etcds are not collocated with masters
Summary: control plane install failed if etcds are not collocated with masters
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Michael Gugino
QA Contact: Gan Huang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-20 08:18 UTC by Gan Huang
Modified: 2018-07-30 19:13 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:13:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:13:51 UTC

Description Gan Huang 2018-04-20 08:18:36 UTC
Description of problem:
Currently as etcd and master are setup via static pods, it indicates that the etcd hosts or masters hosts must be collocated with bootstrap nodes. In this case, control plane install failed if etcd isn't collocated with master.

Version-Release number of the following components:
openshift-ansible-3.10.0-0.22.0.git.0.b6ec617.el7.noarch.rpm

How reproducible:
always
Steps to Reproduce:
1. Trigger HA installation that the etcd hosts aren't collocated with masters
# cat inventory ()
<--snip-->
[masters]
master[1-3]

[nodes]
master[1-3]
etcd[1-3]
node[1-3]

[etcd]
etcd[1-3]



Actual results:
control plane install failed as etcd static pods weren't triggered yet.(bootstrap nodes didn't start at this point)

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Gan Huang 2018-04-20 08:20:14 UTC
Blocking external etcd (not collocated with masters) testing.

Comment 2 Scott Dodson 2018-04-20 14:38:26 UTC
Clayton,

Do we need to support this or can we drop it? I assume if so we'd want to provision node on the etcd hosts and then provision the etcd static pod on them.

What should we do for upgrades?

Comment 3 Michael Gugino 2018-04-30 16:27:30 UTC
We need to re-enable rpm installs per discussion.

Comment 4 Michael Gugino 2018-04-30 19:46:15 UTC
PR Created: https://github.com/openshift/openshift-ansible/pull/8204

Comment 5 Wei Sun 2018-05-07 03:02:26 UTC
The PR seems like has been merged to 3.10.0-0.32.0,please check.

Comment 7 Gan Huang 2018-05-09 07:26:56 UTC
Verified in openshift-ansible-3.10.0-0.37.0.git.0.a7daacf.el7.noarch.rpm

1. A separate etcd cluster are installed successfully in rpm installation.

2. For system container installation against with separated etcd set, failed with messages:

Tuesday 08 May 2018  22:53:35 -0400 (0:00:01.089)       0:09:27.193 *********** 
fatal: [qe-ghuang-etcd-1.0508-3kk.qe.rhcloud.com]: FAILED! => {"changed": false, "failed": true, "msg": "etcd stand-alone hosts on atomic is no longer supported. Please co-locate your etcd hosts with masters.\n"}
fatal: [qe-ghuang-etcd-2.0508-3kk.qe.rhcloud.com]: FAILED! => {"changed": false, "failed": true, "msg": "etcd stand-alone hosts on atomic is no longer supported. Please co-locate your etcd hosts with masters.\n"}
fatal: [qe-ghuang-etcd-3.0508-3kk.qe.rhcloud.com]: FAILED! => {"changed": false, "failed": true, "msg": "etcd stand-alone hosts on atomic is no longer supported. Please co-locate your etcd hosts with masters.\n"}

Comment 9 errata-xmlrpc 2018-07-30 19:13:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.