Bug 1569906 - [regression fail] oc cluster up start fail after update to Fedora-28
Summary: [regression fail] oc cluster up start fail after update to Fedora-28
Keywords:
Status: CLOSED DUPLICATE of bug 1568594
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-20 08:49 UTC by JianHong Yin
Modified: 2018-04-20 09:40 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-20 09:40:26 UTC


Attachments (Terms of Use)

Description JianHong Yin 2018-04-20 08:49:47 UTC
Description of problem:

when update from Fedora-27 to Fedora-28
openshift start up fail.

workaround:
  sudo dnf downgrade -y systemd --releasever=27
  sudo service docker restart

Version-Release number of selected component (if applicable):
latest Fedora-28 and rawhide

How reproducible:
always

Steps to Reproduce:
1. edit /etc/sysconfig/docker
   append "--insecure-registry 172.30.0.0/16" to var OPTIONS
2. sudo service docker restart
3. oc cluster up --image=registry.access.redhat.com/openshift3/ose --version=v3.9

   ^^^ will hang up and never return

Actual results:
# cmdline 'oc cluster up' hang up
and got fail log:
'''
... kubelet.go:1363] Failed to start ContainerManager Delegation not available for unit type
'''

Expected results:
openshift start success

Additional info:
 same issue reported to kubernetes upstream:
  https://github.com/kubernetes/kubernetes/issues/61474#issuecomment-377830563

 the workaround works for me:
  '''
As a workaround until it's fixed dnf downgrade systemd --releasever=27 brought me down from systemd 238 to 234 and I am able to successfully run oc cluster up now
  '''

Comment 1 JianHong Yin 2018-04-20 08:52:15 UTC
works on Fedora-27, add Regression keyword

Comment 2 Zbigniew Jędrzejewski-Szmek 2018-04-20 09:07:20 UTC
Please specify the exact versions of systemd rpms involved.

Comment 3 JianHong Yin 2018-04-20 09:20:45 UTC
(In reply to Zbigniew Jędrzejewski-Szmek from comment #2)
> Please specify the exact versions of systemd rpms involved.

systemd-238-7.fc28.x86_64

Comment 4 Zbigniew Jędrzejewski-Szmek 2018-04-20 09:40:26 UTC
OK. It's already being handled. Please check the update linked in the other bug.

*** This bug has been marked as a duplicate of bug 1568594 ***


Note You need to log in before you can comment on or make changes to this bug.