Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1569972 - [UPGRADES] 9->10 Converge fails: iptables v1.4.21: invalid mask `64' specified
Summary: [UPGRADES] 9->10 Converge fails: iptables v1.4.21: invalid mask `64' specified
Keywords:
Status: CLOSED DUPLICATE of bug 1571840
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 10.0 (Newton)
Hardware: All
OS: All
high
high
Target Milestone: ---
: ---
Assignee: Sofer Athlan-Guyot
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-20 12:06 UTC by Yurii Prokulevych
Modified: 2018-04-27 14:53 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-27 14:53:03 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yurii Prokulevych 2018-04-20 12:06:20 UTC
Description of problem:
-----------------------
Upgrade of RHOS-9 to RHOS-10 on RHEL-7.5 failed during converge step:

openstack overcloud deploy \
--timeout 100 \
--templates /usr/share/openstack-tripleo-heat-templates \
--stack overcloud \
--libvirt-type kvm \
--ntp-server clock.redhat.com \
--control-scale 3 \
--control-flavor controller \
--compute-scale 2 \
--compute-flavor compute \
--ceph-storage-scale 3 \
--ceph-storage-flavor ceph \
-e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml \
-e /home/stack/virt/internal.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation-v6.yaml \
-e /home/stack/virt/network/network-environment-v6.yaml \
-e /home/stack/virt/enable-tls.yaml \
-e /home/stack/virt/inject-trust-anchor.yaml \
-e /home/stack/virt/hostnames.yml \
-e /home/stack/virt/debug.yaml \
-e /home/stack/virt/public_vip.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/tls-endpoints-public-ip.yaml \
-e /usr/share/openstack-tripleo-heat-templates/environments/major-upgrade-pacemaker-converge.yaml
...
2018-04-20 09:36:39Z [AllNodesDeploySteps.ComputeDeployment_Step1.0]: CREATE_FAILED  Error: resources[0]: Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 6
2018-04-20 09:36:39Z [AllNodesDeploySteps.ComputeDeployment_Step1]: CREATE_FAILED  Resource CREATE failed: Error: resources[1]: Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 6
2018-04-20 09:36:40Z [AllNodesDeploySteps.ComputeDeployment_Step1]: CREATE_FAILED  Error: resources.ComputeDeployment_Step1.resources[1]: Deployment to server failed: deploy_status_code: Deployment exited with non-zero status code: 6
2018-04-20 09:36:40Z [AllNodesDeploySteps.ControllerArtifactsDeploy]: CREATE_FAILED  CREATE aborted
2018-04-20 09:36:40Z [AllNodesDeploySteps]: CREATE_FAILED  Resource CREATE failed: Error: resources.ComputeDeployment_Step1.resources[1]: Deployment to server failed: deploy_status_code: Deployment exited with non-zero status code: 6
2018-04-20 09:36:40Z [AllNodesDeploySteps]: CREATE_FAILED  Error: resources.AllNodesDeploySteps.resources.ComputeDeployment_Step1.resources[1]: Deployment to server failed: deploy_status_code: Deployment exited with non-zero status code: 6
2018-04-20 09:36:40Z [overcloud]: UPDATE_FAILED  Error: resources.AllNodesDeploySteps.resources.ComputeDeployment_Step1.resources[1]: Deployment to server failed: deploy_status_code: Deployment exited with non-zero status code: 6

 Stack overcloud UPDATE_FAILED

Checking log from compute-1:
----------------------------
...
Error: Execution of '/usr/sbin/iptables -I INPUT 7 -t filter -s fd00:fd00:fd00:2000::/64 -p udp -m multiport --dports 161 -m comment --comment 124 snmp -m state --state NEW -j ACCEPT' returned 2: iptables v1.4.21: invalid mask `64' specified\nTry `iptables -h' or 'iptables --help' for more information.

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
puppet-firewall-1.8.1-3.e70157egit.el7ost.noarch
puppet-tripleo-5.6.8-1.el7ost.noarch

openstack-tripleo-heat-templates-5.3.10-1.el7ost.noarch

Steps to Reproduce:
-------------------
1. Perform upgrade of RHOS-9 to RHOS-10 (2018-04-18.1)

Additional info:
----------------
Virtual setup: 3controllers + 2computes + 3ceph

Comment 2 Alex Schultz 2018-04-27 14:53:03 UTC

*** This bug has been marked as a duplicate of bug 1571840 ***


Note You need to log in before you can comment on or make changes to this bug.