Bug 1570011 - test case is failing ./tests/bugs/glusterd/add-brick-and-validate-replicated-volume-options.t while brick mux is enabled
Summary: test case is failing ./tests/bugs/glusterd/add-brick-and-validate-replicated-...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sanju
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-20 12:44 UTC by Mohit Agrawal
Modified: 2018-06-20 18:05 UTC (History)
2 users (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-20 18:05:09 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohit Agrawal 2018-04-20 12:44:51 UTC
Description of problem:

Test case is failing ./tests/bugs/glusterd/add-brick-and-validate-replicated-volume-options.t while brick mux is enabled
Version-Release number of selected component (if applicable):


How reproducible:

Always
Steps to Reproduce:
1.Enable brick mux on latest upstream code
2.Run the test case to verify the same
3.

Actual results:
Test case is failing

Expected results:
Test case should not fail

Additional info:

Comment 1 Worker Ant 2018-04-23 10:36:56 UTC
REVIEW: https://review.gluster.org/19924 (glusterfsd: initiate pmap_signout for all detach brick requests) posted (#1) for review on master by Atin Mukherjee

Comment 2 Worker Ant 2018-05-04 04:50:40 UTC
COMMIT: https://review.gluster.org/19924 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- glusterfsd: initiate pmap_signout for all detach brick requests

In glusterfs_handle_terminate all bricks getting detached need to
initiate a pmap_signout.

Change-Id: Iacbd6fcd49215fe6a5210df7dfed1260fde9179a
Fixes: bz#1570011
Signed-off-by: Atin Mukherjee <amukherj@redhat.com>

Comment 3 Shyamsundar 2018-06-20 18:05:09 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.