Bug 1570019 - Regression: libsmbios-2.3.3-6.el7 doesn't provide libsmbios.so.2 for Dell OMSA
Summary: Regression: libsmbios-2.3.3-6.el7 doesn't provide libsmbios.so.2 for Dell OMSA
Keywords:
Status: CLOSED DUPLICATE of bug 1562440
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libsmbios
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Peter Jones
QA Contact: Erico Nunes
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-20 12:52 UTC by Robert Scheck
Modified: 2019-03-01 16:25 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-10 21:45:02 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1562440 None None None 2019-08-20 01:00:13 UTC
Red Hat Knowledge Base (Solution) 3409271 None None None 2018-05-10 20:42:13 UTC

Description Robert Scheck 2018-04-20 12:52:56 UTC
Description of problem:
OM-SrvAdmin-Dell-Web-LX-9.1.0-2757.RHEL7.x86_64_A00.tar.gz from Dell Open
Manage Server Administrator (OMSA) ships various RPM packages, e.g. the
srvadmin-storage-9.1.0-2757.12163.el7.x86_64.rpm which e.g. depends on 
libsmbios.so.2()(64bit). This dependency was satisfied till RHEL 7.5 by
the libsmbios-2.3.3-2.el7.x86_64 package from EPEL. However since RHEL 7.5
there is the newer libsmbios-2.3.3-6.el7.x86_64 package which looks quite
similar by version numbers but it only provides libsmbios_c.so.2 though.

Given libsmbios-2.3.3-6.el7 from RHEL 7.5 breaks vendor-specific software
of an officially supported hardware vendor (Dell), there should be soon a
solution by Red Hat and/or Dell (possibly both together).

Version-Release number of selected component (if applicable):
libsmbios-2.3.3-6.el7.x86_64

How reproducible:
$ Loaded plugins: product-id, search-disabled-repos, subscription-manager
Resolving Dependencies
--> Running transaction check
---> Package libsmbios.x86_64 0:2.3.3-2.el7 will be updated
--> Processing Dependency: libsmbios.so.2()(64bit) for package: srvadmin-storage-8.1.0-4.138.2.el7.x86_64
---> Package libsmbios.x86_64 0:2.3.3-6.el7 will be an update
---> Package smbios-utils-bin.x86_64 0:2.3.3-2.el7 will be updated
---> Package smbios-utils-bin.x86_64 0:2.3.3-6.el7 will be an update
--> Finished Dependency Resolution
Error: Package: srvadmin-storage-8.1.0-4.138.2.el7.x86_64 (installed)
           Requires: libsmbios.so.2()(64bit)
           Removing: libsmbios-2.3.3-2.el7.x86_64 (@epel-testing)
               libsmbios.so.2()(64bit)
           Updated By: libsmbios-2.3.3-6.el7.x86_64 (rhel-7-server-rpms)
               Not found
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Error: Package: srvadmin-storage-8.1.0-4.138.2.el7.x86_64 (installed)
           Requires: libsmbios.so.2()(64bit)
           Removing: libsmbios-2.3.3-2.el7.x86_64 (@epel-testing)
               libsmbios.so.2()(64bit)
           Updated By: libsmbios-2.3.3-6.el7.x86_64 (rhel-7-server-rpms)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
$ 

While above does not use latest OMSA, latest OMSA (9.1.0-2757.RHEL7) still
has exactly the same issue.

Actual results:
libsmbios-2.3.3-6.el7 doesn't provide libsmbios.so.2 for Dell OMSA

Expected results:
libsmbios-2.3.3-6.el7 should also provide libsmbios.so.2 for backward
compatibility for Dell OMSA.

Comment 2 Robert Scheck 2018-04-20 12:59:36 UTC
Cross-filed ticket 02082958 at the Red Hat customer portal.

Comment 4 Anssi Johansson 2018-04-21 02:36:49 UTC
For the record, libsmbios and the related smbios-utils-bin package are also available from Dell's repositories, ie. OMSA does not depend on EPEL, although EPEL's libsmbios package is compatible with OMSA. It is true that 7.5's libsmbios does not provide the required library, which is unfortunate.

http://lists.us.dell.com/pipermail/linux-poweredge/2018-April/051657.html also mentions this same problem.

Comment 5 Sujith 2018-04-23 02:16:17 UTC
Please refer this kbase for RHEL 7.5:
https://access.redhat.com/solutions/3409271

Comment 6 Robert Scheck 2018-04-23 11:00:24 UTC
Sujith, I am sorry, but your kbase document is not a solution but only one
possible workaround (even yum already suggests to use --skip-broken). What
I am looking for is a collaboration between Red Hat and Dell to get this
really addressed one or another way.

Comment 7 Sujith 2018-04-23 13:06:34 UTC
(In reply to Robert Scheck from comment #6)
> Sujith, I am sorry, but your kbase document is not a solution but only one
> possible workaround (even yum already suggests to use --skip-broken). What
> I am looking for is a collaboration between Red Hat and Dell to get this
> really addressed one or another way.

Correct.
It shows that the solution is identified and is in-progress.

Comment 8 Karl Hastings 2018-05-10 20:53:22 UTC

*** This bug has been marked as a duplicate of bug 1562440 ***

Comment 9 Robert Scheck 2018-05-10 21:00:16 UTC
Karl, it is unfortunately not really helpful to mark this public bug report
as a duplicate of a private bug report.

Comment 10 Karl Hastings 2018-05-10 21:45:02 UTC
Hello Robert,

The Kbase article linked has the latest public information on this issue:  https://access.redhat.com/site/solutions/3409271

The Bug I marked this as a duplicate of, Bug 1562440, is the Bug where Dell and Red Hat are communicating on the issue.  Nothing would be copied here.

So, I respectfully disagree.  Closing this BZ as a duplicate of the existing BZ will help to inform others that there *is* in fact an existing BZ (which would not be obvious to anyone otherwise), and it will direct people to the kbase article with the most current and useful information publicly available.  Keeping this BZ open, with no activity on it, gives the incorrect impression that we are not engaged with Dell on solving our mutual customer's issues. 

As soon as I have a public link from Dell regarding this issue, I will add it to the kbase article above.

I will reiterate here, in case anyone finding this doesn't read the linked kbase article:

libsmbios is a Dell owned upstream project:  https://github.com/dell/libsmbios
Dell removed the c++ interface upstream:  https://github.com/dell/libsmbios/issues/27
libsmbios is a *new* package for 7.5.  (EPEL is *not* a supported part of RHEL, and has no ABI/API guarantee.)

If you are using libsmbios from EPEL, you would have had similar issues when EPEL rebases to the newer upstream version.

Please review the kbase article linked for a detailed workaround that involves no loss of functionality.

*** This bug has been marked as a duplicate of bug 1562440 ***

Comment 11 Karl Hastings 2019-03-01 16:25:38 UTC
For completeness, and because this BZ is one of the top search results on Google for this issue, Dell has released a Fix for OMSA, that splits the libsmbios into two packages:
https://www.dell.com/support/home/us/en/04/Drivers/DriversDetails?driverid=3R1H1

This mirrors the RHEL + EPEL solution where libsmbios C language library is shipped in RHEL, and EPEL is now shipping the deprecated c++ library as libsmbios-cpp.

So whether you are using the Dell provided libsmbios packages or the RHEL + EPEL packages, this issue is fully resolved.

At some point Dell will also remove OMSA's dependency on the deprecated c++ library altogether and libsmbios-cpp will no longer be needed.


Note You need to log in before you can comment on or make changes to this bug.