Bug 1570053 - Consistent partitioning within images (was Guest image has more partitions - for remaining images)
Summary: Consistent partitioning within images (was Guest image has more partitions - ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhel-guest-image
Version: 7.6
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Virtualization Maintenance
QA Contact: Wei Shi
URL:
Whiteboard:
Depends On: 1542510
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-20 14:07 UTC by Lubos Kocman
Modified: 2020-06-02 01:58 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1542510
Environment:
Last Closed: 2020-06-02 01:58:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 4 Lubos Kocman 2018-04-20 14:12:52 UTC
Imho autopart --nohome --noswap --nolvm for all

Comment 5 Lubos Kocman 2018-04-20 14:14:50 UTC
Hello Josh, I remember that you've been advocate in history. Do you think it could be achievable?

I expect that Bug 1509350 was really caused by incorrect pykickstart version in buildroot.

Comment 6 Lubos Kocman 2018-04-20 14:32:28 UTC
I'm aligning atomic image with docker image as far as partitioning goes. They both are build for ppc64le and this seem to work.

https://code.engineering.redhat.com/gerrit/#/c/136379

Merging as we can't produce composes and it's a blocker.
We can revisit "unified partitioning later".

Comment 7 Lubos Kocman 2018-04-20 14:32:28 UTC
I'm aligning atomic image with docker image as far as partitioning goes. They both are build for ppc64le and this seem to work.

https://code.engineering.redhat.com/gerrit/#/c/136379

Merging as we can't produce composes and it's a blocker.
We can revisit "unified partitioning later".

Comment 9 Wei Shi 2019-02-18 02:39:53 UTC
Verified on RHEL-7.6-Update-2.0
# guestfish -a rhel-guest-image-7.6-253.x86_64.qcow2 -i list-filesystems
/dev/sda1: xfs


Note You need to log in before you can comment on or make changes to this bug.