Bug 1570055 - SCC admission does not set uids on components in system namespaces
Summary: SCC admission does not set uids on components in system namespaces
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.10.0
Assignee: David Eads
QA Contact: Wang Haoran
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-20 14:20 UTC by Jordan Liggitt
Modified: 2018-07-30 19:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-30 19:13:21 UTC
Target Upstream Version:


Attachments (Terms of Use)
api logs (5.08 MB, text/plain)
2018-05-17 07:44 UTC, zhou ying
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:13:51 UTC

Description Jordan Liggitt 2018-04-20 14:20:51 UTC
Description of problem:

in 3.10, the SCC admission plugin is skipped for components in "run level 0" namespaces (default, kube-system, etc), which means that components running in those namespaces do not have the allocated UID set on their pods.

For components that use persistent storage, that means the uids of the pods do not match the file uid and read errors occur.


Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1. Run 3.9.x, with a registry and persistent storage.
2. Note the uid the registry pods run as.
3. Upgrade to 3.10.x (including updating the registry deployment to redeploy)
4. The registry pods encounter read errors on previously persisted data.
5. Note there is no uid forced onto the pods.

Actual results:


Expected results:


Additional info:

Comment 1 Jordan Liggitt 2018-05-03 17:07:43 UTC
fixed in https://github.com/openshift/origin/pull/19457

Comment 4 zhou ying 2018-05-17 07:44:19 UTC
Created attachment 1437777 [details]
api logs

Comment 10 errata-xmlrpc 2018-07-30 19:13:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.