Bug 1570076 - Where did all my snap GUI apps go?
Summary: Where did all my snap GUI apps go?
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: snapd
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Zygmunt Krynicki
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-20 15:13 UTC by Hayden
Modified: 2018-04-21 17:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-21 02:53:11 UTC
Type: Bug


Attachments (Terms of Use)
yum history (800 bytes, text/plain)
2018-04-20 15:15 UTC, Hayden
no flags Details
yum history info 28 (4.73 KB, text/plain)
2018-04-20 15:16 UTC, Hayden
no flags Details
yum history info 28 (11.45 KB, text/plain)
2018-04-20 15:16 UTC, Hayden
no flags Details
/usr/share/applications files and permissions (11.73 KB, text/plain)
2018-04-20 17:28 UTC, Hayden
no flags Details
~/.local/share/applications files and permissions (1.78 KB, text/plain)
2018-04-20 17:29 UTC, Hayden
no flags Details
log from install of todoist (30.15 KB, text/plain)
2018-04-20 17:29 UTC, Hayden
no flags Details
log from install of telegram (9.72 KB, text/plain)
2018-04-20 17:30 UTC, Hayden
no flags Details
dnf list installed (164.51 KB, text/plain)
2018-04-20 17:32 UTC, Hayden
no flags Details

Description Hayden 2018-04-20 15:13:56 UTC
Description of problem:

All snap GUI apps went missing after I ran a series of fresh updates on Fedora 28 beta last night.

Spotify, Telegram, and Todoist, all installed from snap store, are now gone from applications listing in Gnome.

There are also no more .desktop files in /usr/share/applications or ~/.local/usr/share/applications.

The applications are still visible in gnome-software, are installed, and can be launched from the Terminal.

Uninstalling and then re-installing the applications did not help.

Uninstalling and then re-install snapd and the applications did not help.

I suspect one of the updates broke snap GUI apps.

Version-Release number of selected component (if applicable):

snap    2.32.4-1.fc28
snapd   2.32.4-1.fc28
series  16
fedora  28
kernel  4.16.2-300.fc28.x86_64

How reproducible: All snap-based GUI apps are missing.

Steps to Reproduce:
1. Install snapd and gnome-software-snap.
2. Install any snap GUI app from gnome-software, e.g. Telegram Desktop.

Actual results:

There are no .desktop files created.

Expected results:

Snap GUI apps and their icons appear in Gnome.

Comment 1 Hayden 2018-04-20 15:15:24 UTC
Created attachment 1424565 [details]
yum history

Comment 2 Hayden 2018-04-20 15:16:23 UTC
Created attachment 1424566 [details]
yum history info 28

Comment 3 Hayden 2018-04-20 15:16:43 UTC
Created attachment 1424567 [details]
yum history info 28

Comment 4 Hayden 2018-04-20 15:23:36 UTC
The weird thing is from what I can tell none of the two most recent updates on my Fedora 28 machine, that may have introduced this bug, touched snapd as far as I can tell.

I have attached my yum history and package listing in those upgrades.

Comment 5 Alan Pope 2018-04-20 16:50:28 UTC
I was not able to reproduce this with the following steps.

Installed Fedora 28 beta.
Installed snapd gnome-software-snap
Restarted GNOME Software
Enabled 3rd party repos
Used GNOME Software to install Telegram Desktop from snap store
Checked the icon appears and works
Did a full update with dnf
Rebooted

I still see Telegram in the menu.

I took snapshots all along the way, so happy to provide more debug info if needed.

Comment 6 Hayden 2018-04-20 17:28:16 UTC
(In reply to Alan Pope from comment #5)

It's frustrating when it's not reproducible across systems.

This is what I've just tried:

sudo dnf upgrade
sudo dnf remove snapd gnome-software-snap
sudo rm -r /var/lib/snapd*
sudo rm -r /etc/snap*
sudo shutdown -r now
sudo dnf install snapd gnome-software-snap
gnome-software
(restart gnome-software)
sudo shutdown -r now
gnome-software
(install todoist-thibaut) (see log 1)
sudo shutdown -r now
(nothing in gnome applications or .desktop files)
gnome-software
(install telegram desktop) (see log 2)
(still nothing in gnome applications or .desktop files)

See logs attached.

I don't see anything going wrong during installation.

Permissions appear fine on the .desktop folders.

Comment 7 Hayden 2018-04-20 17:28:48 UTC
Created attachment 1424623 [details]
/usr/share/applications files and permissions

Comment 8 Hayden 2018-04-20 17:29:23 UTC
Created attachment 1424624 [details]
~/.local/share/applications files and permissions

Comment 9 Hayden 2018-04-20 17:29:57 UTC
Created attachment 1424625 [details]
log from install of todoist

Comment 10 Hayden 2018-04-20 17:30:15 UTC
Created attachment 1424626 [details]
log from install of telegram

Comment 11 Hayden 2018-04-20 17:32:32 UTC
Created attachment 1424628 [details]
dnf  list installed

Comment 12 Alan Pope 2018-04-20 21:59:32 UTC
What's the value of XDG_DATA_DIRS? Does it contain the path to /var/lib/snapd/desktop ?

Comment 13 Hayden 2018-04-20 22:19:23 UTC
(In reply to Alan Pope from comment #12)
> What's the value of XDG_DATA_DIRS? Does it contain the path to
> /var/lib/snapd/desktop ?

hayden@fedora ~> printenv XDG_DATA_DIRS
/home/hayden/.local/share/flatpak/exports/share/:/var/lib/flatpak/exports/share/:/usr/local/share/:/usr/share/

Comment 14 Alan Pope 2018-04-20 22:55:53 UTC
There's your problem. Something nerfed /var/lib/snapd/desktop from the end of that search path.

Comment 15 Hayden 2018-04-21 02:53:11 UTC
I am unable to reproduce on a fresh install of Fedora 28.

It's very possible the above might be the culprit.

Please close this bug for now unless someone else runs into it.

Comment 16 Neal Gompa 2018-04-21 17:01:49 UTC
This is most likely because it looks like you're not using Bash, and we don't provide profile snippets for other shells.


Note You need to log in before you can comment on or make changes to this bug.