Bug 1570092 - [RFE] Multiple NICs and different IP address ranges for egress IP
Summary: [RFE] Multiple NICs and different IP address ranges for egress IP
Keywords:
Status: CLOSED DUPLICATE of bug 1437568
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE
Version: 3.7.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.12.0
Assignee: Eric Paris
QA Contact: Xiaoli Tian
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-20 15:40 UTC by Sanket N
Modified: 2018-12-03 12:56 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-03 12:56:14 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Sanket N 2018-04-20 15:40:29 UTC
Description of problem:


1.  Proposed title of this feature request

Openshift should include multiple NICs and different IP address ranges for egress IP instead of node's primary NIC.


2. What is the nature and description of the request?

To overcome the limitation of the cloud provider assigned virtual NIC.


3. Why do you need this? (List the business requirements here)

As the VMware provider do not assign Virtual NIC from the same subnet and cannot enable promiscuous mode So the MacVLAN approach Is not possible.


4. How would you like to achieve this? (List the functional requirements here)

provide multiple nic's (physically and/or virtual via VMware)  for a specific node and attach ip adresses to these nic's from different ip subnets

5. For each functional requirement listed in question 4, specify how Red Hat
   and the customer can test to confirm the requirement is successfully implemented.

see 4.

Comment 5 Sanket N 2018-12-03 12:56:14 UTC

*** This bug has been marked as a duplicate of bug 1437568 ***


Note You need to log in before you can comment on or make changes to this bug.