Bug 1570095 - Warning "Hosted engine should be undeployed before they are removed" popup even after reinstalling HE host by selecting "UNDEPLOY" option.
Summary: Warning "Hosted engine should be undeployed before they are removed" popup ev...
Keywords:
Status: CLOSED DUPLICATE of bug 1579743
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.2.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Simone Tiraboschi
QA Contact: Nikolai Sednev
URL:
Whiteboard:
: 1584919 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-20 15:53 UTC by Ameya Charekar
Modified: 2019-05-16 13:05 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 16:04:49 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)

Description Ameya Charekar 2018-04-20 15:53:56 UTC
Description of problem:

Even after selecting "UNDEPLOY" from under Hosted Engine while removing host following warning will popup when removing host: 
~~~
The hosts marked with * still have hosted engine deployed on them. Hosted engine should be undeployed before they are removed.
~~~

Version-Release number of selected component (if applicable):
rhvm-4.2.2.6-0.1.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Deploy Hosted Engine host
2. Undeploy Hosted Engine host from GUI [optionally run "ovirt-hosted-engine-cleanup" from HE host]
3. Try to remove host

Actual results:
The hosts marked with * still have hosted engine deployed on them. Hosted engine should be undeployed before they are removed.

Expected results:
No warning while removing host.

Additional info:
Same warning message will appear even after executing "ovirt-hosted-engine-cleanup" from HE host:
======
#  /usr/sbin/ovirt-hosted-engine-cleanup
 This will de-configure the host to run ovirt-hosted-engine-setup from scratch. 
Caution, this operation should be used with care.

Are you sure you want to proceed? [y/n]
y
  -=== Destroy hosted-engine VM ===- 
You must run deploy first
  -=== Stop HA services ===- 
  -=== Shutdown sanlock ===- 
shutdown force 1 wait 0
shutdown done 0
  -=== Disconnecting the hosted-engine storage domain ===- 
You must run deploy first
  -=== De-configure VDSM networks ===- 
  -=== Stop other services ===- 
  -=== De-configure external daemons ===- 
  -=== Removing configuration files ===- 
? /etc/init/libvirtd.conf already missing
- removing /etc/libvirt/nwfilter/vdsm-no-mac-spoofing.xml
? /etc/ovirt-hosted-engine/answers.conf already missing
? /etc/ovirt-hosted-engine/hosted-engine.conf already missing
- removing /etc/vdsm/vdsm.conf
- removing /etc/pki/vdsm/certs/cacert.pem
- removing /etc/pki/vdsm/certs/vdsmcert.pem
- removing /etc/pki/vdsm/keys/vdsmkey.pem
- removing /etc/pki/vdsm/libvirt-spice/ca-cert.pem
- removing /etc/pki/vdsm/libvirt-spice/server-cert.pem
- removing /etc/pki/vdsm/libvirt-spice/server-key.pem
- removing /etc/pki/CA/cacert.pem
- removing /etc/pki/libvirt/clientcert.pem
- removing /etc/pki/libvirt/private/clientkey.pem
? /etc/pki/ovirt-vmconsole/*.pem already missing
- removing /var/cache/libvirt/qemu
? /var/run/ovirt-hosted-engine-ha/* already missing
======

Comment 1 Martin Sivák 2018-06-04 16:26:49 UTC
*** Bug 1584919 has been marked as a duplicate of this bug. ***

Comment 2 Martin Sivák 2018-06-26 16:04:49 UTC

*** This bug has been marked as a duplicate of bug 1579743 ***

Comment 3 Franta Kust 2019-05-16 13:05:08 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.