Bug 1570124 - Add warning to API for live migration of VM in different clusters
Summary: Add warning to API for live migration of VM in different clusters
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 4.1.10
Hardware: All
OS: All
low
low
Target Milestone: ovirt-4.2.6
: 4.2.6
Assignee: Emma Heftman
QA Contact: Steve Goodman
URL:
Whiteboard: docs-accepted
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-20 16:40 UTC by amashah
Modified: 2019-05-07 12:45 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-25 11:23:50 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1380783 None None None 2018-04-20 16:45:01 UTC
oVirt gerrit 92442 master MERGED Warn about VM migrations between clusters 2018-07-12 11:23:47 UTC
oVirt gerrit 92989 model_4.2 MERGED Warn about VM migrations between clusters 2018-07-12 12:25:07 UTC

Description amashah 2018-04-20 16:40:53 UTC
Description of problem:

API Guide references the ability to live migrate a VM to another cluster. This feature was only available for a specific use case of upgrading RHEL 6 -> 7 hosts [1] While removing it may be considered a regression, I do think there should be some warning/disclaimer about why it is not recommended. 

Version-Release number of selected component (if applicable):

4.x 

REST API Guide

https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.1/html-single/rest_api_guide/index#services-vm-methods-migrate


Actual results:

6.220.10.1. cluster

Specifies the cluster the virtual machine should migrate to. This is an optional parameter. By default, the virtual machine is migrated to another host within the same cluster. 

Expected results:

6.220.10.1. cluster

Specifies the cluster the virtual machine should migrate to. This is an optional parameter. By default, the virtual machine is migrated to another host within the same cluster. Warning: Live migration to another cluster is not unsupported and considerations for target cluster hardware architecture and network architecture should be strongly considered before attempting. 

Additional info:

[1] https://access.redhat.com/articles/1390733
[2] https://bugzilla.redhat.com/show_bug.cgi?id=1441632

Comment 1 Lucy Bopf 2018-04-26 01:02:23 UTC
This section of the API documentation would have been written by a virt SME, so I'm going to defer this one to the 'Virt' team for review first; if a fix is required, it will need to be submitted as a patch to the API code.

Apologies if component is incorrect. Please reassign as needed.

Comment 3 RHV bug bot 2018-08-06 12:02:15 UTC
WARN: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found non-acked flags: '{'rhevm-4.2.z': '?'}', ]

For more info please contact: rhv-devops@redhat.comINFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found non-acked flags: '{'rhevm-4.2.z': '?'}', ]

For more info please contact: rhv-devops@redhat.com

Comment 5 Steve Goodman 2018-08-14 12:52:42 UTC
We deliver the REST API docs here:

REST API SDK doc:
https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.2/html-single/rest_api_guide/

Version 3 REST API
https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.2/html-single/version_3_rest_api_guide/

The developer is supposed to enter documentation in the code and then a writer is supposed to review it. See:

https://mojo.redhat.com/docs/DOC-1081736#jive_content_id_Process

Comment 6 Martin Sivák 2018-08-14 12:57:18 UTC
Michal, the patches are actually a documentation change in the model exactly as Steve is describing. We never changed any java code here.

Comment 7 Michal Skrivanek 2018-08-14 13:05:06 UTC
it's a java code in model;)

it was reviewed and merged...so, now the only question is when/who regenerates the api guide?
If that's you/doc team then I suggest to move this to VERIFIED

Comment 8 Steve Goodman 2018-08-14 14:43:05 UTC
The doc team should update it. I'll take care of it. It would be helpful to have the query so I can find the patch in Gerrit.

Comment 9 Steve Goodman 2018-08-14 15:05:34 UTC
I don't think that the status should be changed to VERIFIED before I've reviewed the new text.

Comment 11 Michal Skrivanek 2018-08-15 09:19:40 UTC
(In reply to Steve Goodman from comment #8)
> The doc team should update it. I'll take care of it. It would be helpful to
> have the query so I can find the patch in Gerrit.

it's in the list, see external trackers

Comment 16 Steve Goodman 2018-09-25 11:23:50 UTC
This is no published.

Comment 17 Steve Goodman 2018-09-25 11:24:19 UTC
Ha ha. Typo. This is NOW published.


Note You need to log in before you can comment on or make changes to this bug.