Bug 1570149 - [abrt] setroubleshoot-server: _get(): __init__.py:1516:_get:PermissionError: [Errno 13] Permission denied: '/usr/lib/python3.6/site-packages/rednotebook-2.2-py3.6.egg-info/PKG-INFO'
Summary: [abrt] setroubleshoot-server: _get(): __init__.py:1516:_get:PermissionError: ...
Keywords:
Status: CLOSED DUPLICATE of bug 1563797
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:e20f563f47d831ab76f16d480c9...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-20 18:00 UTC by bugzilla@softskills.nl
Modified: 2018-11-29 11:53 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-29 11:53:22 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (2.94 KB, text/plain)
2018-04-20 18:00 UTC, bugzilla@softskills.nl
no flags Details
File: cgroup (278 bytes, text/plain)
2018-04-20 18:00 UTC, bugzilla@softskills.nl
no flags Details
File: cpuinfo (1.39 KB, text/plain)
2018-04-20 18:00 UTC, bugzilla@softskills.nl
no flags Details
File: environ (88 bytes, text/plain)
2018-04-20 18:00 UTC, bugzilla@softskills.nl
no flags Details
File: mountinfo (4.01 KB, text/plain)
2018-04-20 18:00 UTC, bugzilla@softskills.nl
no flags Details
File: namespaces (129 bytes, text/plain)
2018-04-20 18:00 UTC, bugzilla@softskills.nl
no flags Details
File: open_fds (301 bytes, text/plain)
2018-04-20 18:00 UTC, bugzilla@softskills.nl
no flags Details

Description bugzilla@softskills.nl 2018-04-20 18:00:36 UTC
Description of problem:
login

Version-Release number of selected component:
setroubleshoot-server-3.3.17-1.fc28

Additional info:
reporter:       libreport-2.9.4
cmdline:        /usr/bin/python3 -Es /usr/sbin/setroubleshootd -f ''
crash_function: _get
exception_type: PermissionError
executable:     /usr/sbin/setroubleshootd
interpreter:    python3-3.6.5-1.fc28.x86_64
kernel:         4.16.2-300.fc28.x86_64
runlevel:       N 5
type:           Python3
uid:            989

Truncated backtrace:
__init__.py:1516:_get:PermissionError: [Errno 13] Permission denied: '/usr/lib/python3.6/site-packages/rednotebook-2.2-py3.6.egg-info/PKG-INFO'

Traceback (most recent call last):
  File "/usr/sbin/setroubleshootd", line 35, in <module>
    from setroubleshoot.util import log_debug
  File "/usr/lib/python3.6/site-packages/setroubleshoot/util.py", line 324, in <module>
    from sepolicy import get_all_file_types
  File "/usr/lib/python3.6/site-packages/sepolicy/__init__.py", line 9, in <module>
    import setools
  File "/usr/lib64/python3.6/site-packages/setools/__init__.py", line 22, in <module>
    import pkg_resources
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3088, in <module>
    @_call_aside
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3072, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3101, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 565, in _build_master
    ws = cls()
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 558, in __init__
    self.add_entry(entry)
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 614, in add_entry
    for dist in find_distributions(entry, True):
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 1964, in find_on_path
    for dist in factory(fullpath):
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2034, in distributions_from_metadata
    root, entry, metadata, precedence=DEVELOP_DIST,
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2473, in from_location
    py_version=py_version, platform=platform, **kw
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2835, in _reload_version
    md_version = _version_from_file(self._get_metadata(self.PKG_INFO))
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2437, in _version_from_file
    line = next(iter(version_lines), '')
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 2627, in _get_metadata
    for line in self.get_metadata_lines(name):
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 1408, in get_metadata_lines
    return yield_lines(self.get_metadata(name))
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 1404, in get_metadata
    value = self._get(self._fn(self.egg_info, name))
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 1516, in _get
    with open(path, 'rb') as stream:
PermissionError: [Errno 13] Permission denied: '/usr/lib/python3.6/site-packages/rednotebook-2.2-py3.6.egg-info/PKG-INFO'

Local variables in innermost frame:
path: '/usr/lib/python3.6/site-packages/rednotebook-2.2-py3.6.egg-info/PKG-INFO'
self: <pkg_resources.PathMetadata object at 0x7fc2a4412a58>

Comment 1 bugzilla@softskills.nl 2018-04-20 18:00:44 UTC
Created attachment 1424635 [details]
File: backtrace

Comment 2 bugzilla@softskills.nl 2018-04-20 18:00:45 UTC
Created attachment 1424636 [details]
File: cgroup

Comment 3 bugzilla@softskills.nl 2018-04-20 18:00:47 UTC
Created attachment 1424637 [details]
File: cpuinfo

Comment 4 bugzilla@softskills.nl 2018-04-20 18:00:49 UTC
Created attachment 1424638 [details]
File: environ

Comment 5 bugzilla@softskills.nl 2018-04-20 18:00:50 UTC
Created attachment 1424639 [details]
File: mountinfo

Comment 6 bugzilla@softskills.nl 2018-04-20 18:00:52 UTC
Created attachment 1424640 [details]
File: namespaces

Comment 7 bugzilla@softskills.nl 2018-04-20 18:00:53 UTC
Created attachment 1424641 [details]
File: open_fds

Comment 8 Vit Mojzis 2018-11-29 11:53:22 UTC

*** This bug has been marked as a duplicate of bug 1563797 ***


Note You need to log in before you can comment on or make changes to this bug.