Bug 1570152 - Dynamic check box does not update in Classic UI
Summary: Dynamic check box does not update in Classic UI
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Tina Fitzgerald
QA Contact: Niyaz Akhtar Ansari
URL:
Whiteboard:
Depends On:
Blocks: 1571976
TreeView+ depends on / blocked
 
Reported: 2018-04-20 18:16 UTC by Shveta
Modified: 2019-02-11 14:01 UTC (History)
15 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1571976 (view as bug list)
Environment:
Last Closed: 2019-02-11 14:01:58 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
dialog (2.48 KB, text/x-vhdl)
2018-04-20 18:16 UTC, Shveta
no flags Details
Automate method (3.02 KB, application/zip)
2018-04-20 18:17 UTC, Shveta
no flags Details

Description Shveta 2018-04-20 18:16:08 UTC
Created attachment 1424643 [details]
dialog

Description of problem:


Version-Release number of selected component (if applicable):
5.9.1.2.20180321221247_67fd99d

How reproducible:


Steps to Reproduce:
1. import the dialog and method attached.
2. create a catalog item with above dialogs.
3. Order catalog item . 
4. checkbox does not auto update on selecting True/False in first dropdown as it should according to the method.

Actual results:


Expected results:


Additional info:
Appliance : https://10.8.196.249
Service - Bz_reproducer

Comment 2 Shveta 2018-04-20 18:17:28 UTC
Created attachment 1424644 [details]
Automate method

Comment 4 Shveta 2018-04-20 19:52:36 UTC
This is also a bug in SUI

Comment 5 Chris Hale 2018-04-20 20:22:08 UTC
So I can help shortcut this for someone on the Classic UI team.  This issue was with ui-components repo and was solved already.  The SUI currently has the fix applied for this version of release but because of how the SUI uses NPM for dependency updates and Classic UI uses bower, I suspect when it was fixed and version bumped in SUI, it might not have gotten version bumped in bower and integrated and retested in Classic UI.   This should be a fairly simple fix for someone to lookup and apply a newer version on Classic UI.

Comment 6 Greg McCullough 2018-04-23 17:35:50 UTC
Hit submit too soon last time.

Erik - I believe you might have a work-around for this issue.  Please add details here.

Comment 8 Chris Hale 2018-04-24 17:30:55 UTC
We will need a couple of more GH pull requests after this one gets merged.  SUI and Classic UI need PR's created after this fix is released to take advantage of the fix.

Comment 9 CFME Bot 2018-04-24 19:50:16 UTC
New commit detected on ManageIQ/ui-components/master:

https://github.com/ManageIQ/ui-components/commit/454b998b06fef24291fb3a3581385d1a6d8a3a6e
commit 454b998b06fef24291fb3a3581385d1a6d8a3a6e
Author:     Erik Clarizio <eclarizio@gmail.com>
AuthorDate: Mon Apr 23 14:28:26 2018 -0400
Commit:     Erik Clarizio <eclarizio@gmail.com>
CommitDate: Mon Apr 23 14:28:26 2018 -0400

    Use updated vaules as default for checkbox when field is dynamic

    https://bugzilla.redhat.com/show_bug.cgi?id=1570152

 src/dialog-user/services/dialogData.spec.ts | 43 +-
 src/dialog-user/services/dialogData.ts | 9 +
 2 files changed, 42 insertions(+), 10 deletions(-)

Comment 10 eclarizi 2018-04-25 16:17:23 UTC
In response to Greg and clearing the needinfo:

I was able to fix the issue on the reproducing appliance by removing the default value for the checkbox in the database. Alternatively I suppose you could export the dialog, manually edit the yaml to not have a default value for the checkbox field in question, and then re-import.

Comment 11 Chris Hale 2018-04-25 20:23:41 UTC
GH PR for Service UI to take advantage of this bugfix on G release.  https://github.com/ManageIQ/manageiq-ui-service/pull/1426

Comment 12 Chris Hale 2018-04-25 20:40:58 UTC
GH PR for Classic UI to take advantage of the bugfix on G release.  https://github.com/ManageIQ/manageiq-ui-classic/pull/3845

Comment 15 William Fitzgerald 2018-05-01 14:00:05 UTC
Waiting for new build

Comment 16 William Fitzgerald 2018-05-02 14:11:00 UTC
Works on 5.9.2.4 SUI

Comment 19 Niyaz Akhtar Ansari 2018-09-04 08:25:55 UTC
Verified in Version 5.10.0.14.20180831154906_2f9a1dd


Note You need to log in before you can comment on or make changes to this bug.