Bug 157024 - segmentation fault with glXChannelRectSyncSGIX
segmentation fault with glXChannelRectSyncSGIX
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
: 161175 190023 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-06 05:00 EDT by Luya Tshimbalanga
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-30 07:03:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luya Tshimbalanga 2005-05-06 05:00:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050504 Fedora/1.0.3-4 Firefox/1.0.3

Description of problem:
From either icons and console, openoffice.org won't start because of segmentation fault

Version-Release number of selected component (if applicable):
openoffice.org-1.9.100

How reproducible:
Always

Steps to Reproduce:
1. On console mode, type openoffice.org or simply start any openoffice.org application
2.
3.
  

Actual Results:  Segmentation fault

Expected Results:  OpenOffice.org should start

Additional info:

Current system:
CPU: AMD Athlon XP2500+ Barton
Motherboard: Gigabyte K7 Triton GA-7VM400M-P
Videocard: NVidia Geforce FX 5600XT
Memory: 1GB DDR-RAM
Storage: 120 GB HDD WD + 40 GB HDD Maxtor
Media: built-in soundcard, 32X CD burner, 16X DVD-ROM drive, floppy drive, 4 USB ports back and 2 USB port front
OS: Fedora Core 3 (kernel 2.6.10-1.770_FC3), Fedora Core 4 Test 2 and Windows XP Professional
Case: X-Case ICute 302 featuring 3 system cooling fan, 1 CPU fan Aero 7 LITE
Comment 1 Jeremy Katz 2005-05-18 20:54:41 EDT
Can you provide a backtrace of the segfault?
Comment 2 Dave King 2005-05-28 12:50:06 EDT
I am also having this same problem.  Since Luya has not yet responded, here's a
backtrace from my system:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 4141775680 (LWP 7312)]
0x00000000 in ?? ()
(gdb) bt
#0  0x00000000 in ?? ()
#1  0x006a2955 in pthread_once () from /lib/libpthread.so.0
#2  0xf663bd8e in glXChannelRectSyncSGIX () from /usr/lib/libGL.so.1
#3  0xf666d1f8 in ?? () from /usr/lib/libGL.so.1
#4  0xf663c0fc in _init () from /usr/lib/libGL.so.1
#5  0x00000000 in ?? ()
(gdb)  

Details on my system:
CPU: AMD Athlon 64 Processor 3500+
Motherboard: ASUS A8N-SLI
Videocard: Triple headed system using two Jaton PCI video cards with NVidia
GeForce4 MX 440 AGP8X chips and NVIDIA's proprietary driver
Memory: 2GB DDR-RAM
Storage: 120 GB Serial ATA drive using sata_nv driver
Media:  Realtek ALC850 onboard chip using NVIDIA's proprietary driver
OS: FC4 test3 + updates, kernel 2.6.11-1.1363_FC4 #1
Comment 3 Dave King 2005-05-28 13:53:04 EDT
Ok, so that backtrace suggested a conflict in the video driver.  I reconfigured
X to use the "nv" driver that comes with FC instead of the proprietary NVidia
driver and the problem went away.  Guess my problem isn't with OpenOffice after all.
Comment 4 Mike A. Harris 2005-05-30 07:03:13 EDT
Thanks for the report.  For users who are experiencing problems
installing, configuring, or using the unsupported 3rd party
proprietary "nvidia" video driver, Nvidia provides indirect
customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and
passes them on to Nvidia engineers for investigation.  Once
they've isolated a particular problem, it is often fixed in
a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums,
others who may have experienced the particular problem may
be able to assist.  If there is a real bug occuring, Nvidia
will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system
releases that they officially support.

While Red Hat does not support the proprietary nvidia driver,
users requiring technical support may also find the various
X.Org, XFree86, and Red Hat mailing lists helpful in finding
assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Setting status to "NOTABUG" (unsupported).
Comment 5 Eric Work 2005-06-16 08:13:53 EDT
I have found a solution though its more of a work around. (OO.org 1.9-109)

1. Download the xorg-x11-Mesa-libGL-XXX.i386.rpm file from the redhat website.
http://download.fedora.redhat.com/p...core/updates/4/

2. Force install the rpm, "rpm --force -Uvh xorg-x11-Mesa-libGL-XXX.i386.rpm",
to replace the missing files /usr/X11R6/lib/libGL.so.* removed by the NVIDIA
installer

3. Modify the script "/usr/lib/openoffice.org2.0/program/soffice". Change this
block of code:

===== BEGIN =====

*)
# this is a temporary hack until we can live with the default search paths
if [ $LD_LIBRARY_PATH ]; then
SYSTEM_LD_LIBRARY_PATH=$LD_LIBRARY_PATH
export SYSTEM_LD_LIBRARY_PATH
LD_LIBRARY_PATH="/usr/X11R6/lib:$sd_prog:$moz_lib":$LD_LIBRARY_PATH
else
LD_LIBRARY_PATH="/usr/X11R6/lib:$sd_prog:$moz_lib"
fi
export LD_LIBRARY_PATH
;;

===== END =====

The changes are the addition of /usr/X11R6/lib to the LD_LIBRARY_PATH
enviornment variable. This will force the OO.org to load the software GL driver
first.

4. Test OO.org with something like "oowriter"
Comment 6 Caolan McNamara 2005-06-16 08:31:39 EDT
or instead add 
export SAL_NOOPENGL=true 
to the top of your /usr/lib/openoffice.org2.0/program/soffice
Comment 7 Caolan McNamara 2005-06-21 07:51:50 EDT
*** Bug 161175 has been marked as a duplicate of this bug. ***
Comment 8 Caolan McNamara 2006-04-28 04:10:31 EDT
*** Bug 190023 has been marked as a duplicate of this bug. ***
Comment 9 Luya Tshimbalanga 2006-04-28 13:16:11 EDT
My own problem is solved with the latest version of Fedora Core 5. I use livna
version instead of official Nvidia driver.
Comment 10 Nicolas A. Barriga 2006-06-16 00:43:20 EDT
I had the same problem with FC5 x86_64. The problem was that i installed the 
32bit libGL.so.1 when installing the nvidia driver. To solve it, i just removed 
/usr/lib/libGL.so.1 , so it will find the right one(at /usr/lib64)

Note You need to log in before you can comment on or make changes to this bug.