Bug 1570256 - python35: test_buffer check fails on ppc64le
Summary: python35: test_buffer check fails on ppc64le
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python35
Version: 28
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 1540995
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2018-04-21 08:32 UTC by Miro Hrončok
Modified: 2019-03-14 11:21 UTC (History)
11 users (show)

(edit)
Clone Of: 1540995
(edit)
Last Closed: 2019-03-14 11:21:48 UTC


Attachments (Terms of Use)

Description Miro Hrončok 2018-04-21 08:32:39 UTC
+++ This bug was initially created as a clone of Bug #1540995 +++

======================================================================
FAIL: test_memoryview_struct_module (test.test_buffer.TestBufferProtocol)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/Python-3.5.5/Lib/test/test_buffer.py", line 2540, in test_memoryview_struct_module
    self.assertEqual(m[1], nd[1])
AssertionError: -21.099998474121094 != -21.100000381469727
----------------------------------------------------------------------
Ran 72 tests in 16.169s
FAILED (failures=1)

Version-Release number of selected component (if applicable):
python3-3.5.5-1.fc28


How reproducible:
100%


Steps to Reproduce:
1. Build python35 with test_buffer enabled in rawhide

Additional info:
The test was disabled in 3.5.5-1 so that the F28 rebuild can happen.


--- Additional comment from Iryna Shcherbina on 2018-02-27 20:22:54 CET ---

The culprit might be in the gcc update.

The test works with gcc-7.2.1-2.fc27.ppc64le, but if you update to gcc-8.0.1-0.14.fc28.ppc64le it starts to fail.

Comment 1 Petr Viktorin 2019-01-07 13:48:19 UTC
Setting this to low priority.

It would be great if someone else would get to this earlier than we can. If that's your case, please assign the bug to yourself (and adjust priority accordingly).

Comment 2 Victor Stinner 2019-03-05 13:29:54 UTC
This issue is duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1540995 but for Python 3.5: this bug is caused by a compiler bug which has been fixed in Rawhide:
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=88892


Note You need to log in before you can comment on or make changes to this bug.