Bug 1570257 - need to update image of sync pods in openshift-node project
Summary: need to update image of sync pods in openshift-node project
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Scott Dodson
QA Contact: Weihua Meng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-21 08:36 UTC by Weihua Meng
Modified: 2018-05-09 12:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-05-09 12:49:02 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Weihua Meng 2018-04-21 08:36:57 UTC
Description of problem:
the image of sync pods in openshift-node project is using old one (openshift3/node), should be updated to openshift3/ose-node

The images for ovs pods and sdn pods in openshift-sdn project are already updated to right one. bz1566406

Version-Release number of the following components:
openshift-ansible-3.10.0-0.26.0.git.0.dbc127c.el7

How reproducible:
Always

Steps to Reproduce:
1. install OCP 3.10
2. check image used for sync pods in openshift-node project

Actual results:
2. old image (openshift3/node) used.
# oc get pods -o yaml -n openshift-node | grep image:
      image: registry.reg-aws.openshift.com:443/openshift3/node:v3.10

Expected results:
the image of sync pods in openshift-node project is updated to openshift3/ose-node

Comment 1 Scott Dodson 2018-04-21 15:17:42 UTC
Marked as a TestBlocker because without fixing this there's no telling what other problems will occur.

Comment 2 Johnny Liu 2018-04-23 02:56:24 UTC
There are several places using "node" image but not "ose-node" in openshift-ansible code, all of them should be updated.

roles/openshift_bootstrap_autoapprover/defaults/main.yaml:
osn_image: "{{ l_os_registry_url | regex_replace(l_os_prefix | regex_escape, 'node') }}"

roles/openshift_node_group/defaults/main.yml:
osn_image: "{{ l_os_registry_url | regex_replace(l_os_prefix | regex_escape, 'node') }}"

Comment 4 Weihua Meng 2018-04-26 00:59:08 UTC
Fixed.
openshift-ansible-3.10.0-0.29.0

# oc get pods -o yaml -n openshift-node | grep image:
      image: registry.reg-aws.openshift.com:443/openshift3/ose-node:v3.10
      image: registry.reg-aws.openshift.com:443/openshift3/ose-node:v3.10

Kernel Version: 3.10.0-862.el7.x86_64
Operating System: Red Hat Enterprise Linux Server 7.5 (Maipo)


Note You need to log in before you can comment on or make changes to this bug.