Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1570298 - unable to export all service dialogs
Summary: unable to export all service dialogs
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.8.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: GA
: 5.10.0
Assignee: eclarizi
QA Contact: Shveta
URL:
Whiteboard:
Depends On:
Blocks: 1589837
TreeView+ depends on / blocked
 
Reported: 2018-04-21 18:28 UTC by Reartes Guillermo
Modified: 2019-02-11 14:04 UTC (History)
12 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1589837 (view as bug list)
Environment:
Last Closed: 2019-02-11 14:04:16 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Reartes Guillermo 2018-04-21 18:28:03 UTC
Description of problem:

There are too many dialogs, so i tried to backup all and then start deleting the older or unused ones.
But i was unable to export all service dialogs at the same time.

When performing an export of all service dialogs (there are a lot of long dialogs) one
gets an 502 error and it is not possible to export the dialogs.

Version-Release number of selected component (if applicable):
5.8.x (also encountered on 5.9.x)

How reproducible:
always

Steps to Reproduce:
1. Go to Automation -> Automate -> Customization -> Select Import Export
2. Select all existing dialogs (almost 100 dialogs)
3. Press the button "Export"
4. After some time, the error 502 appears.
5. Individual or sometimes a group of dialogs can be exported

Actual results:
unable to export all dialogs

Expected results:
being able to export all existing dialogs

Additional info:
On the logs one can see that the dynamic methods are being executed.
This lasted a lot of time, due to the quantity and complexity (several dynamic methods) of the dialog.
I found very strange that the methods are being executed when just exporting the dialog as a yaml.

Comment 2 Greg McCullough 2018-04-23 14:40:40 UTC
We are aware of the dynamic methods running in this scenario and working on a fix.

Reartes - As a work-around can the dialogs be exported in smaller batches?

Comment 3 Reartes Guillermo 2018-05-04 12:28:00 UTC
Hi,

Yes, one can export a smaller groups of dialogs. 

Cheers.

Comment 5 drew uhlmann 2018-06-06 17:12:47 UTC
https://github.com/ManageIQ/manageiq/pull/17436

Comment 6 drew uhlmann 2018-06-07 12:53:11 UTC
I think this should be checked in latest 5.9, thanks!

Comment 8 Shveta 2018-07-03 18:38:53 UTC
Dynamic methods are not executed while exporting dialogs .
Verified in 5.10.0.2.20180626170006_40dc459


Note You need to log in before you can comment on or make changes to this bug.