Bug 1570299 - SELinux is preventing bluetoothd from 'open' accesses on the arquivo /var/lib/bluetooth/40:49:0F:C1:0F:18/settings.
Summary: SELinux is preventing bluetoothd from 'open' accesses on the arquivo /var/lib...
Keywords:
Status: CLOSED DUPLICATE of bug 1567385
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:57fbbdf28f764397ba497f1dab1...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-21 18:50 UTC by isabellefk
Modified: 2018-04-27 12:48 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-27 12:48:42 UTC
Type: ---


Attachments (Terms of Use)

Description isabellefk 2018-04-21 18:50:52 UTC
Description of problem:
SELinux is preventing bluetoothd from 'open' accesses on the arquivo /var/lib/bluetooth/40:49:0F:C1:0F:18/settings.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that bluetoothd should be allowed open access on the settings file by default.
Then você deve informar que este é um erro.
Você pode gerar um módulo de política local para permitir este acesso.
Do
allow this access for now by executing:
# ausearch -c 'bluetoothd' --raw | audit2allow -M my-bluetoothd
# semodule -X 300 -i my-bluetoothd.pp

Additional Information:
Source Context                system_u:system_r:init_t:s0
Target Context                system_u:object_r:bluetooth_var_lib_t:s0
Target Objects                /var/lib/bluetooth/40:49:0F:C1:0F:18/settings [
                              file ]
Source                        bluetoothd
Source Path                   bluetoothd
Port                          <Desconhecido>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-283.30.fc27.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.13.9-300.fc27.x86_64 #1 SMP Mon
                              Oct 23 13:41:58 UTC 2017 x86_64 x86_64
Alert Count                   3
First Seen                    2018-04-13 14:43:14 -03
Last Seen                     2018-04-14 12:34:41 -03
Local ID                      1297ad27-8db8-4cb5-853b-1656d1fb6454

Raw Audit Messages
type=AVC msg=audit(1523720081.682:2017): avc:  denied  { open } for  pid=980 comm="bluetoothd" path="/var/lib/bluetooth/40:49:0F:C1:0F:18/settings" dev="dm-0" ino=2237739 scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:bluetooth_var_lib_t:s0 tclass=file permissive=0


Hash: bluetoothd,init_t,bluetooth_var_lib_t,file,open

Version-Release number of selected component:
selinux-policy-3.13.1-283.30.fc27.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.3
hashmarkername: setroubleshoot
kernel:         4.15.14-300.fc27.x86_64
type:           libreport

Potential duplicate: bug 1494936

Comment 1 Lukas Vrabec 2018-04-27 12:48:42 UTC

*** This bug has been marked as a duplicate of bug 1567385 ***


Note You need to log in before you can comment on or make changes to this bug.