Bug 1570339 - Firefox can not play H.264 videos using FFmpeg 3.5
Summary: Firefox can not play H.264 videos using FFmpeg 3.5
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-22 01:44 UTC by Antoine Cotten
Modified: 2018-05-29 07:58 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-29 07:58:39 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 1435212 None None None 2019-07-22 15:06:52 UTC
Red Hat Bugzilla 1570281 None CLOSED RFE: Please add ffmpeg-4.0 support (patch suppiled) 2019-07-22 15:06:52 UTC

Description Antoine Cotten 2018-04-22 01:44:56 UTC
Description of the problem:

On Fedora 28 beta, with ffmpeg installed from the OS repository, Firefox can not play H-264-encoded MP4 videos.


Version-Release number of selected component (if applicable):

firefox-59.0.2-1.fc28.x86_64
ffmpeg-3.5-0.6.20180305git.fc28.x86_64


How reproducible:

Visit https://www.quirksmode.org/html5/tests/video.html and try to play the video labeled "H.264/MP4".

Another relevant test: https://developer.jwplayer.com/tools/stream-tester/?playerversion=8.


Actual results:

HTML5 videos can not be played.


Expected results:

HTML5 videos can be played (as they are on Fedora 27).

Comment 1 Antoine Cotten 2018-04-22 01:54:33 UTC
Correction: ffmpeg comes from RPMfusion (http://download1.rpmfusion.org/free/fedora/development/28/Everything/x86_64/os/Packages/f/)

Comment 2 Martin Stransky 2018-04-23 08:14:19 UTC
Works for me on Fedora 28 / Firefox 59.0.2. I have those ffmpeg packages installed:

rpm -qa \*ffmpeg\*
compat-ffmpeg28-2.8.14-1.fc28.x86_64
gstreamer-ffmpeg-0.10.13-19.fc28.x86_64
ffmpeg-libs-3.5-0.6.20180305git.fc28.x86_64

Comment 3 Antoine Cotten 2018-04-23 13:12:50 UTC
"compat-ffmpeg28" must be the key here since Firefox does not (to my knowledge) use Gstreamer anymore.

According to the referenced upstream bug, compatibility with FFmpeg 3.5+ will be part of the Firefox 61 release.

Comment 4 Antoine Cotten 2018-05-29 07:58:39 UTC
Fixed in Firefox 60 (see external bug).

Tested with
* firefox-60.0-4.fc28.x86_64
* ffmpeg-4.0-1.fc28.x86_64


Note You need to log in before you can comment on or make changes to this bug.