Bug 1570361 - Premature LOGOUT disconnect on SSL connections - BYE not flushed / correctly sent (RHEL6)
Summary: Premature LOGOUT disconnect on SSL connections - BYE not flushed / correctly ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dovecot
Version: 6.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Michal Hlavinka
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-22 10:31 UTC by Graham Leggett
Modified: 2019-07-03 13:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-03 12:29:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1570017 None NEW Premature LOGOUT disconnect on SSL connections - BYE not flushed / correctly sent 2019-07-03 13:22:17 UTC

Description Graham Leggett 2018-04-22 10:31:34 UTC
Description of problem:

When an IMAP client connecting to dovecot sends the LOGOUT command, dovecot immediately terminates the connection, and the BYE response is not sent to the client.

This in turn triggers further bugs in Limilabs IMAP client / Docuware, which in turn renders it impossible for Docuware v6.12 to log in successfully to a Redhat SSL IMAP server.

Version-Release number of selected component (if applicable):

dovecot-2.0.9-22.el6.x86_64

How reproducible:
Steps to Reproduce:
Actual results:
Expected results:

All identical to https://bugzilla.redhat.com/show_bug.cgi?id=1570017

Additional info:

Downloaded the SRPM for dovecot and applied the following two patches, and the problem was fixed:

https://dovecot.org/list/dovecot-cvs/2014-June/024504.html
https://www.dovecot.org/list/dovecot-cvs/2014-June/024509.html

The same fix for 1570017 for RHEL7 applies here and fixes the problem in RHEL6.


Note You need to log in before you can comment on or make changes to this bug.